WordPress.org

Support

Support » Plugins and Hacks » Ultimate Blogroll » [Resolved] [Plugin: Ultimate Blogroll] "addlink" and "more" link don't work

[Resolved] [Plugin: Ultimate Blogroll] "addlink" and "more" link don't work

Viewing 15 replies - 1 through 15 (of 21 total)
  • I have the same problem after updating to the latest WP…
    Work’t fine before…
    I rely hope the developer will fix this problem soon…
    Love this plug-in!!!

    I go to the page, and click the “addlink”, nothing happens… when I click the “more” ?? tried to reinstalled it but not working!!
    on my blog: hXXp: ottsjopunkten.tk, please help me:)

    Can this plugin be fixed please? It’s awesome but not if it’s not working 🙂

    I have the same problem on 3 sites, addlink & more does not work.

    Hey Guys. I was testing out this plugin and found the same issues. I’m not sure where the developer is, so I dug into the code and found a quick fix.
    If you are not comfortable or capable of editing a file directly through wordpress, then this is NOT going to work for you and this is only a temporary solution until the developer does something about the problem.

    1) From your WordPress Dashbord, go to your Plugins -> Editor section.
    2) Look on the upper-right hand corner of the page for a dropdown-list “Select plugin to edit:” which contains a list of your plugins.
    3) Select the Ultimate Blogroll from the list.
    4) On the right of the page, you will see “Plugin files”.
    5) Locate the file “ultimate-blogroll/domain/Widget.php”.
    6) Click on the file to load it in the editor.
    7) Do a text search in your browser (CTRL-F in Firefox) and search for “More”. This will take you to the 2 offending lines of code:

    $gui .= "<li><a href=\"".get_permalink(Mapper::getInstance(Mapper::Settings)->getConfig("permalink"))."\">".__("More", "ultimate-blogroll")."</a></li>";
    $gui .= "<li><a href=\"".get_permalink(Mapper::getInstance(Mapper::Settings)->getConfig("permalink"))."#wp-add-your-site\">".__("Add link", "ultimate-blogroll")."</a></li>";

    I’m really not sure what the purpose of the “More” link really is, so I removed it entirely. On the second “Add Link” line, here is what you should replace it with, making sure to change the section “your-link-page-here” to whatever your link page url is. Notice the single quotes and make sure you do the same.

    8) $gui .= "<li><a href='/your-link-page-here/#wp-add-your-site'>Add Your Link</a></li>";
    9) Save the page and that’s it! You’re done. Test it out and make sure it’s working, if not, go back in and edit the file according. I customized the anchor text “Add link” to “Add Your Link” for my own personal taste, you can modify as you wish.

    If you have any problems, just reply here. Thanks to the developer of the plugin and hopefully you come back with an update to fix this properly, rather than my edit.

    Cheers and hope you all get it working.

    I have the same problem. I tested the nhr2k solution, but didn´t work.
    Does someone can help me in order to solve this problem.
    Thanks in advance.

    Hey Webgames. I looked at your site and the link to your page is working, but for some reason your link page is empty. You may want to try and creating or re-creating the page and selecting it again from the Ultimate Blogroll settings. I added the plugin to and your link to my blog, so you can see for yourself here. Let me know how it goes.

    I tried it:( and my blog crashed!

    Sorry to hear that. Where’s the link to your blog?

    Hi nhr2k, I already try again to create, recreate the page but still not working. Do you have more ideas?

    Hey Webgames. Seems like the edit you followed from me worked. For some reason, the plugin is not generating the info for your link page. Maybe there is a plugin or template conflict. I’m sure what it could be. You would have to go step by step disabling each plugin to see which one may be causing the issue. You an email me directly and maybe I can help you better. just put “me@” in front of the name of my blogs domain, and thats my email address. Good luck with whatever you choose to do.

    donramon

    @donramon

    who knowe’s how to remove the link Cadeauwebwinkel.be n/a n/a n/a n/a n/a

    in editor where can i find the link in editor to remove in Ultimate Blogroll

    @donramon Take a look at the UB settings page and turn off “Support developer”. Have you gotten the plugin to work properly?

    donramon

    @donramon

    certainly overlooked thanks nhr2k , and thanks for your tip for the quick fix “addlink” works well here thanks 😉

    Just thought I’d let everyone know, that Webgames and I were able to get the plugin working for him on his website. My quick-fix worked, but there is a conflict with Ultimate Blogroll and other plugins that use Facebook features, “like” button. So if your issue is the link page is blank, check for those kind of conflicting plugins.

    Good luck everyone.

    Please! HELP ME! http://ottsjopunkten.tk/your-link-page-here/#wp-add-your-site
    I cannot get it working!

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘[Resolved] [Plugin: Ultimate Blogroll] "addlink" and "more" link don't work’ is closed to new replies.
Skip to toolbar