WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Udinra All Image Sitemap] Sitemap not formed correctly – fixed!

[Resolved] [Plugin: Udinra All Image Sitemap] Sitemap not formed correctly – fixed!

  • thewisebunny
    Member

    @thewisebunny

    Great plugin – I haven’t managed to find one that can grab images from absolutely everywhere, including the standard wordpress galleries and featured images.

    However it wasn’t forming the XML correctly – any special characters in the post url weren’t being broken out in the XML. For example, I had a number of URL’s that included ampersands.

    If you have similar issues, try changing line 104 in udinra-all-image-sitemap.php to:
    $udinra_xml .= "\t\t"."<loc>".htmlspecialchars($udinra_post_url)."</loc>"."\n";

    cheers

    rog

    http://wordpress.org/extend/plugins/udinra-all-image-sitemap/

Viewing 2 replies - 1 through 2 (of 2 total)
  • thewisebunny
    Member

    @thewisebunny

    Just updated to latest versino of plugin. For anyone with the problem outlined above, the new line to change is 178

    Cheers

    rog

    Aloysius314
    Member

    @aloysius314

    Great, thanks for that info thewisebunny. For me, it was line 174, but for anyone else with this issue, just look in that general neighborhood and you will be able to match the code with the correct line.

    Cheers

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] [Plugin: Udinra All Image Sitemap] Sitemap not formed correctly – fixed!’ is closed to new replies.