Toolset Types
[Plugin: Types - Custom Fields and Custom Post Types Management] Delete Custom Taxonomy not working (7 posts)

  1. mickyharris
    Posted 4 years ago #

    Using Version Types.

    I cannot delete an unused custom taxonomy in admin, it just hangs with the spinning wheel going round. I tried Types => Custom Types and Taxonomies => Delete Permanently.

    Also a minor point I think - the description for the Custom Taxonomies on the Custom Types and Taxonomies screen in admin shows the description for the last Custom Type entered, rather than the actual description entered for the Taxonomy.

    Hoping you can help, thanks.


  2. Amir Helzer
    Plugin Author

    Posted 4 years ago #

    Have a look at the 'debugging' page on our site:

    See if you're getting any Javascript or PHP errors and please let us know about them.

  3. Naz
    Posted 4 years ago #

    I'm having a similar—if not the same—problem.

    When I use the slug 'books' in a custom post type I get a 404 page when I try to load a post in it. I think there may have been a different post type that used the same slug, but this post type has been deleted. I think (just guessing here) the problem is that the slug hasn't been properly removed from the database, so WordPress thinks the slug already exists and doesn't recognise it as the new post type's slug (even after deleting my post type the post type is still listed in my database).

    I also noticed that the taxonomy description, if left empty, uses the description of one of the post types. In my case, it uses the last one on the list.

  4. Amir Helzer
    Plugin Author

    Posted 4 years ago #

    To reset the rewrite rules and flush out and orphan data, go to the permalinks page and save.

  5. mickyharris
    Posted 4 years ago #

    I believe my problems were related to using a reserved term in the taxonomy in case that helps anyone:

    However, was not able to fully test this as I removed the Types plugin and registered my own post type and taxonomies in my functions file.

    This looks like a good tutorial for doing that:

  6. Naz
    Posted 4 years ago #

    @AmirHelzer I have tried that but sadly enough it didn't fix the problem.

    @mickyharris I'm glad to see you've found a solution!

  7. Amir Helzer
    Plugin Author

    Posted 4 years ago #

    Good point about reserved names. I'm adding this to our todo list for the next release. Types should not allow to create items with reserved names.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Toolset Types
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic