Support » Plugin: Twitter Widget Pro » [Plugin: Twitter Widget Pro] Tweets not updating – bug

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Author Aaron D. Campbell


    This is weird. It seems as though the stored data isn’t expiring for some reason. Do you have access to run a query on your database (maybe through phpMyAdmin or something)? If so, can you tell me what you get back from this:
    SELECT * FROM wp_options WHERE option_name LIKE '_transient_%twp_%' || option_name LIKE '_transient_%tlc_%'

    (if you changed your table prefix, make sure that wp_options is whatever your options table is)

    HI Aaron, thanks for replying. I do have access to phpmyadmin – can you give me some pointers as to what I need to do exactly? Am i just looking for info in tables? Or do you want me to send a request to teh database somehow and see what I get back? (in which case can you explain it abit so i know where an dhow to do it? sorry!)

    if it’s any help, the problem started for me when I upgraded from 2.3.2 to 2.3.3..

    ok i’ve worked out how to do a database query. Not sure which bit of the results you want though. Also looks like there might be stuf in there I don’t want to share with the world?! Let me know what I should post up.

    thank you

    I did as you suggest and changed the url in my wp-twitter-widget.php code line 185 to http (not https) and I then get the “no tweets” message i.e. it works the opposite way round for me??

    My problem isn’t that I’m not getting tweets, it’s that I’m not getting any updated tweets and the widget is stuck on whatever day i set the number of tweets.

    Any suggestions? This site is meant to be going live tomorrown!

    thanks in advance

    I am having the the same issue. Ever since I updated to 2.3.3 the twitter widget doesn’t update. However if I change the number of tweets to display it will update with more recent tweets but will not continuously update like it has in the past.

    I’ve had to deactivate this plugin as I cna’t get it to work and have decided to use twitter’s own widget rather than rely on a plugin. it doesn’t have some of the nice features that this plugin has but it’s pretty much the same.
    Go here to try it out

    I would do that, but the styling on the site I’ve created is tied into the twitter feed. Looking into the code myself to see if I can figure out why its not working.

    This is shocking – I don’t understand how a plugin update can mess things up this badly. I really don’t want to resort to the default Twitter widget, as this one has worked so well in the past.

    I too am seeing ‘stuck’ tweets that won’t update until I change the display number. Although changing it back just breaks it again. I’ve changed the code on line 186 from https to http but still no joy.

    Pleeeeeeese fix this (once fantastically simple and elegant) plugin!

    Looked into the code but can’t see what could be causing it.

    +1 for fixing.

    I’ve stopped using this now, and have started using Twitter Feed for WordPress which is working perfectly out of the box. I recommend you do the same if you’ve had issues.

    I went with twitter tools. Only downside is that plugin only allows for one widget in a sidebar. Had to install another plugin to insert PHP into a sidebar widget to add more. Otherwise its working great. I hope this plugin gets fixed. It worked to well to ignore.

    Same problem here in the Netherlands. I also don’t get this widget to work properly. Can anyone please tell me what I’m doing wrong?

    Latest version of WordPress & latest version of Twitter Widget Pro.
    My WP-website is hosted on a Danish hosting-provider in Denmark.

    Https shows me my twittername, amount of followers and “no tweets available”
    Http shows me my twittername, amount of followers, tweets posted, but won’t update the timeline. Even when I wait about 24/48/72 hours or more, no difference.

    When I hit the clear-update-locks button I got the message “There were no locks to clear!” So that’s not the problem I think, but what makes it not to work the way this widget is supposed to do?

    I’ve tried to uninstall/reinstall the widget, deactivating/activating, but no change at all.

    Please help!

    By the way… the WordPress-theme I’m using is Coraline. Does anyone knows if that is perhaps the cause why this widget won’t work properly?

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘[Plugin: Twitter Widget Pro] Tweets not updating – bug’ is closed to new replies.