Support » Plugins and Hacks » Twitter Widget Pro » [Plugin: Twitter Widget Pro] Not Receiving Updates

[Plugin: Twitter Widget Pro] Not Receiving Updates

  • I am having a problem getting my feeds (from 2 diff twitter accts) to update. I updated the plug in yesterday. I also added Better WP Security yesterday. Towards the end of the day I noticed that the feeds were not updating. It is not an API issue as it did not update overnight.

    I thought there may be a conflict with the Better WP Security plugin, so I disabled that plugin and there still was no updates.

    I deleted Twitter Widget Pro and reinstalled and it still only shows the tweets that were in place when I deleted it.

    Do you have any thoughts on what may be causing the feed to not update?



Viewing 15 replies - 1 through 15 (of 25 total)
  • Plugin Author Aaron D. Campbell


    Honestly this is still likely an API limit issue. It often happens on shared hosting when another site on your server (or server cluster) starts pounding on the API and using up all the requests. Since the limit is only 150 requests per hour per IP, it’s not that hard to exceed your hourly limit in as little as half a second if someone is doing something wrong (purposefully or otherwise).

    If you’re running the latest version of Twitter Widget Pro, go into “WP-Admin->Settings->Twitter Widget” and it will tell you want your API usage currently is. Check that first to see if that’s the problem. If it is, ask your host to move you to a server that’s behind a different IP.

    The API limit still shows remaining items after at least 20 minutes, which should be plenty of time for the feeds to update.

    Plugin Author Aaron D. Campbell


    Yep, the feed should update every 5 minutes assuming that the site is getting visitors (no visitors, no updates). In that same setting page, try clearing the locks.

    I have cleared the locks repeatedly and I am refreshing from different PC’s to test it and I am still not getting updates.

    Another odd point, when I change the number of posts to display, it repopulates with current data, but then locks again and won’t refresh unless I change something else.

    Any further thoughts?

    When I put the widget back to the old number of posts, it removes the new posts and reverts back to where it was frozen.

    Hi Aaron, thank you for this great plugin, I’ve been using it for months and it’s been great. However, since yesterday, I’ve starting experiencing the exact same problem as NYG8OR.

    – When I change any TWP settings and refresh my page, tweets are shown. Then when I refresh again they disappear, “no available tweets”

    -I updated to the new version hoping it will fix the problem, but it didn’t.

    -My remaining API never reaches 0, and even after API limit reset, problem still remains, nothing changes. (I don’t think it’s an API issue)

    -Another thing I noticed: TWP is not fetching tweets from local cache when it should. If I refresh the page after 20 seconds the tweets that were there before disappear, why not fetch tweets from cache instead of twitter if it’s an API issue? And why does TWP only fetch tweets from twitter when changes have been made to settings, even when hours have passed?

    Any help is much appreciated, thanks.

    I need to add to this.

    Plug in has been working perfectly on my website (dedicated server) for months and all of a sudden the feeds have stopped.

    I have updated the plugin to the most recent version, tried changing https (which is what it has been on with no issues since i set it up in july/august) to http – i have cleared update locks – nothing nothing at all.

    The only thing i have tried is changing the number of tweets to show from 2 to 3 (it worked on first load then they went back to “No Tweets Available”

    Something funky has happened in the last few days.

    I have used:55, Remaining:95 Limit resets in 7 mins.

    Any ideas, answers suggestions?

    Thanks in advance but this need to be resolved. Seems to be many people with similar issues but no answers.



    Yeah – i have this on our site http://www.linskills.co.uk/ – just stopped working – been working perfectly until several days ago.

    Marlon Amancio


    Hi all,

    I’ve just installed now, I had never used it, and does not working.

    Plugin looks like great, looking forward to use it.




    Also here, plugin was working fine until a few days ago, now updates are stuck.

    I guess it’s a plugin and not user issue because so many users report the same problem

    Plugin Author Aaron D. Campbell


    Wow, this thread is all over the place. If you’re bringing up something similar but not exactly the same please start a new thread. It’s VERY hard to answer multiple problems in one thread.

    NYG8OR: Do scheduled posts work for you? Try scheduling a post to publish in the future and see if it publishes when it should. The requests to Twitter are scheduled in much the same way.

    WQ32: The plugin DOES cache the results from Twitter. It stores the response as an option and stores a second option with an expire date/time. It will continue to use the results forever, but once the time has expired it will try to update that option with new results (on failure to update though, it will continue to use the old data).

    Dan Davies: It’s likely that something else has changed. Maybe a security update on your server closed off self-requests (where the server requests a page from itself)? These are used to trigger the update process that grabs fresh data from Twitter. As for “many people” having this problem, over 14,000 people have downloaded the plugin since the new version was released. It looks like maybe 10 have a problem, so that’s less than a tenth of a percent…which I actually think is quite good.

    info@nwonline.co.uk: Try checking your API limits (WP-Admin->Settings->Twitter Widget) and testing scheduled posts as mentioned above.

    marlonlamancio: “Does not work” isn’t really enough of a description to work off. Please start a new support thread with as much information as you can (what specifically does it do? Were you able to add the widget to a sidebar? What settings are you using? etc)

    panmoria: Try checking your API limits (WP-Admin->Settings->Twitter Widget) and testing scheduled posts as mentioned above. Also, I’ll re-iterate what I said to Dan. It looks like maybe as many as 10 people are having this problem, but more than 14,000 have downloaded and installed the new version. Less than 1/10th of one percent doesn’t seem like “many people”. I’m not trying to be a pain, just trying to keep things in perspective.



    Is there some sort of debug mode to give you better clues of why the plugin just stopped working a week ago? I guess you’ll get more and more error reports as time goes on.

    Plugin Author Aaron D. Campbell


    panmoria: I already gave you two things to check. Please let me know what your API limits show and also let me know how the scheduled post works.



    API usage:

    Used: 0
    Remaining: 150
    Limits reset in: 60 minutes

    About scheduled posts I can report later.

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘[Plugin: Twitter Widget Pro] Not Receiving Updates’ is closed to new replies.