WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Twitter Widget Pro] No Tweets Available

[Plugin: Twitter Widget Pro] No Tweets Available

Viewing 15 replies - 1 through 15 (of 53 total)
  • Plugin Author Aaron D. Campbell
    Participant

    @aaroncampbell

    Usually this means that your server can’t connect to the Twitter servers. Likely because you’re on a shared server and the IP has been limited or blocked. Do any other twitter widgets like Wickett Twitter Widget work?

    Ryan Andrews
    Member

    @andrwsryan

    I fixed the problem in the code. The twitter api feed is not secure, you use https:// , it should be http://

    According to twitter’s website, the api feed url is:

    http://api.twitter.com/1/statuses/user_timeline.format

    Hope this helps you. Twitter Widget Pro is working great for me now 😀

    Plugin Author Aaron D. Campbell
    Participant

    @aaroncampbell

    Not sure what to tell you, other than that if you change it to http:// it works flawlessly and if it is https:// the widget reads “No Tweets Available”

    Ryan

    FWIW, I’d been wrestling with the same problem for the past couple days. I just edited the code as Ryan suggested, and now my Twitter Widget Pro is working too…

    vlogolution
    Member

    @vlogolution

    we had the same problem, and changing from https:// to http:// worked for us too – thanks!

    no problem, that is definitely the issue. It works on all the servers I’ve tried when this fix is applied.

    Widget shows No Tweets Available. Using the most recent release and other Twitter feeds work so it’s not my hosting company blocking Twitter. I’m on a dedicated IP anyway. I switched the https to http as suggested above and it appears to be working.

    Plugin Author Aaron D. Campbell
    Participant

    @aaroncampbell

    I’m worried that the real issue is not http vs https. I think that all the change is doing is changing the hash so that whatever is stuck in the database is being ignored. You could try running this query to clear out the stored data and see if that helps:
    DELETE FROM wp_options WHERE option_name LIKE '_transient_%twp_%' || option_name LIKE '_transient_%tlc_%'
    (if you changed your table prefix, make sure that wp_options is whatever your options table is)
    You may want to run SELECT * FROM wp_options WHERE option_name LIKE '_transient_%twp_%' || option_name LIKE '_transient_%tlc_%' first to take a look at what you’re deleting.

    More feedback about this. I’ve changed my URL to http and is working. I think if you are requesting tweets from a HTTPS page the https url works, but if you are requesting them from a HTTP page it doesn’t work.

    I have double checked the SELECT you recommend, and there are no records in the XX_options table with that condition, so I think this is not the problem…

    Hope it helps.
    Marcos.

    I can also confirm that the widget is working fine again after changing to http instead of https

    Dries

    blueidea05
    Member

    @blueidea05

    It Works!
    Just modify “https” to “http” in line 186 within wp-twitter-widget.php

    Just to say that even in my case, switching from https to http solved the issue.

    redrockettattoo
    Member

    @redrockettattoo

    Probably a stupid question but…how do I get to the code in order to edit it?

    redrockettattoo
    Member

    @redrockettattoo

    Sorry…found the code. Just not sure where exactly I’m supposed to change https to http…

Viewing 15 replies - 1 through 15 (of 53 total)
  • The topic ‘[Plugin: Twitter Widget Pro] No Tweets Available’ is closed to new replies.