Support » Plugin: Twitter Widget Pro » [Plugin: Twitter Widget Pro] Broken after WP update to 3 version

  • After WP update plugin is still in the plugin list and in the widget list and I even can add the widget to sidebar, but there is nothing appears on the site. Tried in defferent themes – the same.

    I loved this plugin and I do hope it will be repaired but for now I’ve delited it and Looking for another one

    Good luck!

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Aaron D. Campbell

    (@aaroncampbell)

    The plugin is definitely compatible with all 3+ versions of WordPress (currently 3.0.x, 3.1.x, and 3.2.x). Can you test with the default theme and all other plugins disabled? It’s likely that you have another plugin that’s conflicting with it.

    Drake

    (@marcoragogna)

    It does not work also for me, don’t know why but it display always “Could not connect to Twitter”.

    I changed the return of _getFeedUrl to

    return sprintf( ‘http://api.twitter.com/1/statuses/user_timeline.json?include_entities=true&include_rts=true&screen_name=%1$s&count=%2$s’, $widgetOptions[‘username’], $count );

    but I am not an expert. I don’t know if it is correct, but with this fix now it works for me.

    Plugin Author Aaron D. Campbell

    (@aaroncampbell)

    It’s been a while since I’ve had a chance to really go through Twitter Widget Pro, and it seems the Twitter API endpoints have changed. I’ll release a new version in the next few days (Probably 2.3.0, maybe 2.2.4 depending on how much I get done) that will use the new URLs.

    It does not work also for me, don’t know why but it display always “Could not connect to Twitter”.

    I changed the return of _getFeedUrl to

    return sprintf( ‘http://api.twitter.com/1/statuses/user_timeline.json?include_entities=true&include_rts=true&screen_name=%1$s&count=%2$s’, $widgetOptions[‘username’], $count );

    but I am not an expert. I don’t know if it is correct, but with this fix now it works for me.

    Worked for me too! Thanks Drake.

    For everyone else,

    in wp-twitter-widget.php

    Replace lines 636 to 662 with

    return sprintf( 'http://api.twitter.com/1/statuses/user_timeline.json?include_entities=true&include_rts=true&screen_name=%1$s&count=%2$s', $widgetOptions['username'], $count );

    Thanks again Drake.

    IGNORE THAT LAST ONE!!!

    Line 179 in wp-twitter-widget.php, simply change

    private $_api_url = 'https://api.twitter.com/1/';

    to

    private $_api_url = 'http://api.twitter.com/1/';

    Cheers

    Thanks danny_c
    It works for me

    Thanks danny_c….. it worked for me tooo…. but why am i getting only one post for twitter …. i mean it only shows one post from twitter even when i put two or three or any number of post in setting of the Twitter pro.
    i changed it in

    How many items would you like to display?

    I applied above modification to the plugin

    Hey guys, i am little worried to be hurry so i gave up for this plugin even it is great, so i moved to twitter website and got a great help by a simple javascript, if you like guys. Anyway i am posting this if this may help some of you guys who’s noob like me… not totally…

    follow this link to add widget of twitter in your site,

    http://twitter.com/goodies/widgets

    You rock danny_c!

    Plugin Author Aaron D. Campbell

    (@aaroncampbell)

    So you guys are saying that your server can connect to Twitter but NOT via HTTPS? I guess that since we’re not sending any auth info or sensitive data I might be able to switch, but eventually it’ll get switched back because I want to be able to auth to work with private accounts, etc.

    What hosts are you on and have you talked to your host about the issue?

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Plugin: Twitter Widget Pro] Broken after WP update to 3 version’ is closed to new replies.