Support » Plugins and Hacks » [Plugin: Twitter Tools] Twitter update from post didn’t include link!

[Plugin: Twitter Tools] Twitter update from post didn’t include link!

Viewing 15 replies - 1 through 15 (of 21 total)
  • You’re not the only one. I noticed the same problem. I’m not sure how to fix it, but at least you’re not alone!

    Glad I’m not alone. I’m hoping the developer takes a look at it. I’m usually loathe to change plugin code, as any updates would wipe out the changes.

    Happened to me as well. I left a comment on the developer’s site informing him of the bug, but his only response was to try to sell me technical support services.

    I’ve since switched to other plugins.

    I left a comment on the developer’s site informing him of the bug, but his only response was to try to sell me technical support services.

    Since this “bug” only seems to affect people who have incorrectly entered their username and API key, I thought it appropriate to let you know where you could get support to resolve the issue for you. I’m sorry you found this offensive.

    My username and API key were correctly entered. That was double and triple-checked. Twitter Tools didn’t post a URL with the tweet regardless of whether or not the bit.ly plugin was activated and set up. It didn’t work no matter what I tried.

    That makes it a bug.

    I’ve had the same experience as LMAshton except I’ve not had any interaction with Mr. King.
    My bit.ly url is not being posted on Twitter from any of my blogs. This is a change from the previous behaviour. I have not changed anything on the three blogs within the time frame of the bit.ly failure using Twitter Tools. I can see it happening to several other folks in my Twitter stream as well.
    I will gladly switch back to Twitter Tools once it functions for me again. For now, it’s been removed.
    Thank you.

    I noticed that I didn’t even have the bit.ly settings set. Whoops.

    I haven’t tested it yet though.

    But it seems to me that if I didn’t have those set, Twitter Tools would revert to the previous behavior of adding the long-form link.

    On my blogs (three, by the way), without the bit.ly plugin, no URL at all was given in the tweet, long version or short, so I had zero luck with getting anything resembling any kind of URL on any tweet.

    For the record, the behavior I mentioned in previous tweets was identical on all three blogs.

    My username and API were also correctly entered, but if this problem is just being caused by the URL shortener, I’ll disable the bit.ly plugin and see if it works. I do not have this plugin enabled on another blog, and it is correctly sending tweets.

    I’m having the same issue. My new blog posts are generating tweets on my twitter page, but there is no link back to the post. My bit.ly account info is correct. I’m currently using WordPress 2.8.4 and Twitter Tools 2.0. If anyone had any luck getting this to work I would be interested in hearing how.

    For what it’s worth, I deactivated all Twitter Tools plugins, then reactivated without the bit.ly plugin and was able to generate a tweet with a link back to the new post. I then activated the bit.ly plugin, at which pointed I noticed a trailing space after my API key (from my copy and paste?). Once I removed the space, I saw the links on my bit.ly page.

    Same problems here.. I tried deactivating, and reactivating, re-installing.. to no avail. Strange how it just stopped suddenly. I switched to TweetSuite for now… Hoping there’s a fix soon. I really liked Twitter Tools

    @alexkingorg… My API key is entered correctly…I’ve triple checked it…

    I’ve been using the plugin successfully for many months now. I had not messed with the settings at all when it just stopped working. It will tweet out the title, but no longer includes the bit.ly link.

    I’ve just managed to get the plugin working. As Alex King says above that this only affects users “incorrectly entered their username and API key” I thought that this was worth looking into. Although to the naked eye my username and API looked absolutely fine there was a blank space after my API key (a result of copying and pasting from my bit.ly account). I deleted this blank space and published a test post which worked perfectly and included the shortened url. Really pleased that this is now working as I use it on 4 blogs. I hope that this solution works for others.

    Best wishes,

    reallgooddomains had the same issue as me. There was an extraneous space in the copy/pasted API key from bit.ly.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘[Plugin: Twitter Tools] Twitter update from post didn’t include link!’ is closed to new replies.