Support » Fixing WordPress » [Plugin: Twitter Tools] Not updating posts from FeedWordPress

  • Hey all– not sure if this is the right place, but I had twitter tools and FeedWordPress working happily alongside one another for a couple of days, and then suddenly, twitter tools stopped sending updates with the auto-posts. Has anyone else had this problem?

    Site is http://www.insurgencywatch.com.

    Thanks!
    Chris

Viewing 12 replies - 1 through 12 (of 12 total)
  • I am having the same issue.

    Alex King, I am having Twitter Tools vs. FeedWordPress problems also.

    Is there any way to get them to play nice? Are they mutually exclusive?

    Error messages point to various parts of rss-related WordPress files: “Fatal error: Call to a member function do_blog_post_tweet() on a non-object in […]/wp-content/plugins/twitter-tools.php on line 740.”

    This is a shame because being able to aggregate content via FeedWordPress and in turn, send that out to Twitter (automagically) is a stellar concept.

    Note: some posts here attribute the problems to (FeedWordPress’ install of) MagpieRSS, however, even after replacing all WP RSS files with the originals, still no joy.

    Help us Alex-Wan Kenobi, you’re our only hope! 🙂

    As long as FeedWordPress (or any other plugin) uses standard WordPress APIs and processes, everything should work fine.

    Thanks Alex. There does seem to be some sort of problem; either one works well alone on my sites, but both do not seem to work together. Here’s the latest error (top of homepage on a reload).

    Warning: Illegal offset type in […]/wp-includes/rss.php on line 1459

    Here’s what my homepage displays (twilightnewssite.com), occasionally, though on reload it displays the page fine(?!).

    Warning: Illegal offset type in
    […]/wp-includes/rss.php on line 1459

    Warning: Cannot modify header information – headers already sent by
    (output started at
    […]/wp-includes/rss.php:1459) in
    […]/wp-includes/pluggable.php on line
    865

    Note this is with Twitter Tools (and similar) plugins deactivated.

    Deactivating FeedWordpress now. Hope we get some feedback here on how this can be fixed.

    Anyone have better experiences with another RSS feed + wordpress plugin?

    I tried feed.informer.com, which has handy filtering qualities (e.g., remove same titles/URL posts), but it displays via javascript so there’s no SEO impact. Which is a big reason for posting RSS feeds from other sites on your own site in the first place…

    When I try to (re-)activate feedwordpress with twitter tools activated, I get the following error:

    Fatal error: Call to a member function do_blog_post_tweet() on a non-object in […]/wp-content/plugins/twitter-tools.php on line 740

    Line 740 in twitter-tools.php says:

    738 function aktt_notify_twitter($post_id) {
    739 global $aktt;
    740 $aktt->do_blog_post_tweet($post_id);
    741 }
    742 add_action(‘publish_post’, ‘aktt_notify_twitter’, 99);

    Just did a clean WP install with feedwordpress. Worked fine.

    Added Twitter Tools. Would post to Twitter directly, but would not post to twitter when new posts were added. Same as above.

    Uninstalled Twitter Tools and tried (( WP Twitter ))

    Success! It works! 88 miles per hour!

    feedwordpress + (( WP Twitter )) = Easy autoblogging, rss aggregating, joy.

    P.S. Did not do the magpie rss upgrade feedwordpress requests, but does not require.

    From what you’ve illustrated here, it appears that FeedWordPress circumvents standard WP processes to do its work. Twitter Tools will likely never work with it as long as this is the case. Glad you found another option.

    kesseret

    (@kesseret)

    I use wordtwit with feedwordpress. It works pretty well. Hope this helps.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Plugin: Twitter Tools] Not updating posts from FeedWordPress’ is closed to new replies.