Support » Plugin: Twitter Tools » [Plugin: Twitter Tools] No longer publishing tweets as a blog post

  • I set up 2.4 successfully with OAuth without any problems about a week ago. However, since yesterday I noticed tweets are no longer being published to my blog as posts. I checked my SQL database ak_twitter and noticed it has not received any new tweets since around noon on the 29th.

    Could this be related to the issues surrounding OAuth? Is anyone else having the same issue?

    As far as I know sending notification of new posts TO Twitter still works at least.

Viewing 15 replies - 1 through 15 (of 18 total)
  • I should add, I tried manually updating and resetting Tweet Checking with no effect.

    I can post TO twitter from sidebar widget, and new posts are sent to twitter as tweets

    But, all incoming stuff such as displaying recent tweets in sidebar, or making weekly digest of tweets, has stopped functioning for me

    Yep, that’s exactly what’s happening in my case.

    Ok, I re-registered an app with Twitter and reset the keys and tokens as a result.

    I can post to Twitter, but again, NONE of the tweets I send is being converted into a post on my blog like it used too. It was working fine and now it just simply stopped.

    fyi- I’m getting the same problem on my site as well. wp 3.0.1, twitter tools 2.4. fetching tweets from twitter just fine for sidebar widget and weekly digests, but not putting in new tweets for each post. I made sure the read only vs. full access flag in the twitter app setup was set to full access. Thanks for the great plug-in, looking forward to getting this cleared up.

    Several days, not a single update. My ak_twitter database that stores the tweets has not been updated since the 28th.

    Any suggestions on troubleshooting this, or has Twitter finally hosed this feature of the plugin for good?

    I have the same issue. If tt is not clogged up, its double posting.

    Does Twitter’s API not allow importing tweets anymore? Just seems suspicious that this suddenly stopped working out of the blue a week after I installed 2.4.

    Same issue with TwitterTools 2.4 + WordPress 3.0.1.
    When creating a new blog post, a tweet is posted. But the tweets are no longer imported in the TwitterTools tables 🙁

    I’ve also been careful with Twitter app configuration: “read/write” enabled.

    Yup, I’ve been through everything I can think of, my output WordPress to Twitter is fine, but my input Twitter to WordPress is non-existant since upgrade

    Update: I got it working! For now…

    Rev Voodoo, nicolasleroy: Out of curiosity do you have any other Twitter related plugins installed? Take a good luck and see if you have any other plugin besides Twitter Tools that interacts with Twitter. I want to see if there’s a possible correlation here.

    In addition, I got mine working by disconnecting the connection in Twitter Tools again, then I went to set up a brand new app all over again. The only difference I made was not to include anything in the “Organization” field, and I didn’t upload an application icon either. Trivial changes that shouldn’t have made a difference at ALL, and yet this app is working successfully now. I have always set read/write access every time I created an app so that should not have be an issue either.

    I tried creating a new app before with no success, I have no idea why it suddenly worked now. That’s why I suspect there might be an issue with having multiple Twitter related plugins all using OAuth to access Twitter.

    I’ve been using “Simple Twitter Connect” to enable Twitter authentication to post comments… I have disabled this plugin, have created another app, have registered it in Twitter Tools. Still no luck 🙁

    You might have to wait a day or so. A few days passed before I tried registering another app again to see if it worked. In the meantime I opened a ticket with Twitter.

    Looking around, Network Publisher plugin seems to work for me.

    hmm, I don’t have any other plugin using OAuth with twitter

    I may try to make a new app again tho, see what happens

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘[Plugin: Twitter Tools] No longer publishing tweets as a blog post’ is closed to new replies.