WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Twitter Tools] new v2.4 broken/problems?

[Plugin: Twitter Tools] new v2.4 broken/problems?

  • fidgetwith
    Member

    @fidgetwith

    I got this error when trying to set the new twitter tools plugin:

    Fatal error: Class ‘OAuthSignatureMethod_HMAC_SHA1’ not found.

    Seems i’m not the only one accoring to this:
    http://crowdfavorite.com/forums/forum/twitter-tools

    Also seems to need PHP5 and cURL which others have complained about no prior warning and thier hosts do not support it (mine does).

    Any official word yet? I’ve rolled back to v2.31 for now.

    Please fix this otherwise excellent plugin!

Viewing 15 replies - 1 through 15 (of 45 total)
  • yer i am having the same issue,
    Fatal error: Class ‘OAuthSignatureMethod_HMAC_SHA1’ not found in /home/jol227/public_html/wp-content/plugins/twitter-tools/twitteroauth.php on line 62

    I have checked the code and have this on line 62
    $this->sha1_method = new OAuthSignatureMethod_HMAC_SHA1(); i am not a coder but seems right!

    I then sent a request to wordpress help centre as they have their button next to the tt option page, explaining and detailing the above errors and this was thier response…..

    With items such as this, it is generally best to first let us make aninitial evaluation of your site, which costs $100. If the problem canbe solved with a quick fix, we are more than happy to take care of itright then and there. However, if the problem requires a more
    in-depth solution, we will tell you what needs to be done going
    forward and provide you a quote for us to do it. It is difficult to
    determine the exact problem until we have the opportunity to look at
    how your WordPress install is setup, including theme and plugins.

    Given our present workload, our response time for this job is
    approximately 3 business days. This lead time estimate is good for
    the next two (2) business days. Our business is such that our
    workload varies greatly over the course of a few days, so if it takes
    you a few days to consider our quote and get back to us, that lead
    time may change—in either direction.

    If this quote is acceptable, please reply back and we’ll send you an
    invoice to get started.

    `

    well i am in shock, they must now that there are issues with alot of peiople that have been using the pluggin without problems for a long time, seems they want to try and capitalise on it……..

    please excuse my bad typing, feeling rather emotional to say the least!

    Plugin Contributor Alex King
    Member

    @alexkingorg

    I’m sorry that the new version isn’t working for you. August 16th was the deadline for changing to Twitter’s new auth scheme, so unfortunately rolling back to the old version is a fix that isn’t viable long term:

    http://countdowntooauth.com/

    My WordPress HelpCenter team has helped dozens of people this morning at no charge. There are other people who are experiencing problems that we cannot reproduce. In those cases, we are offering to debug and try to resolve the issue on your own server and asking for a fair (actually a discounted) rate to do this.

    WordPress is moving to PHP5 in the near future, so moving away from PHP4 hosting is a good idea.

    Please consider that this plugin is currently made available for free and that my team and I have countless development hours invested in it. We’re trying to provide the best options we can to our users.

    h.lietz
    Member

    @hlietz-1

    Same thing here … That does not seem a singular problem.

    Thanks for your reply, what can i do to fix this error? i have followed the instructions as per the tt options in my dashboard, i have copied and pasted the consumer code and secret and the access token and secret, when i press the coneect to twitter button i get this error
    Fatal error: Class ‘OAuthSignatureMethod_HMAC_SHA1’ not found in /home/jol227/public_html/wp-content/plugins/twitter-tools/twitteroauth.php on line 62

    I have downloaded the php file in my file manager and checked line 62 as indicated by the error and this is what is written

    $this->sha1_method = new OAuthSignatureMethod_HMAC_SHA1();

    I am assuming this is correct!

    please can you enlighten me as to what is the issue?

    thanksyou

    webtiva
    Member

    @webtiva

    I just got this from Twitter DEV:

    ———-

    Application suspension notice

    This is a notice that your OAuth token for Tools 55 has been suspended from interacting with the Twitter API.

    Please make sure that your application follows Twitter’s API Terms of Service

    To request for your token to be re-enabled, please write to api@twitter.com

    ———-

    I created this API following the “Twitter Tools” 2.4 OAuth steps. Works fine, but seems it was a not-authorized behavior based on Twitter TOS. So, I’ll updade manually my blog twits until a new method arrives.

    Waiting so….

    This is most likely the issue you guys are facing (opened a ticket with my web host):

    The problem is with a pecl module that was setup on the server to provide oauth support. It was defining the oauth class first and then the oauth.php can’t redefine it. I disabled this module and the twitter tool should be working now. Please check to confirm.

    Open a ticket with your hosting company to see if they can do the same.

    CoastalData
    Member

    @coastaldata

    Working with my host support now to try and track it down….

    CoastalData
    Member

    @coastaldata

    My host says I’m SOL, that the module is installed, but cannot be used by shared customers on the server itself!

    CoastalData
    Member

    @coastaldata

    Update: My host, btw, is HostGator… I just got an email back from their support department, and they said they would, by request, update my sites individually to fix this problem.

    Specifically, they said this:

    The problem is with a pecl module that includes oauth support for php. It is loaded on our servers and does not have the class OAuthSignatureMethod_HMAC_SHA1 defined. The twiiter tools have a file called oauth.php that defines this class but since the pecl module is already loaded, this does not get defined. If you can please provide a list of sites, we can disable the module so that the oauth.php file gets loaded correctly.

    wechangetheworld
    Member

    @wechangetheworld

    Hi, I’m using wordpress 3.0.1 (before the upgrade I used 2.9.2) and twitter tools with oAuth didn’t work.

    I get the error message:

    Fatal error: Call to undefined function curl_init() in /mnt/web3/40/91/52083491/htdocs/wordpress/wp-content/plugins/twitter-tools/twitteroauth.php on line 201

    Do you have any idea what might be the cause of this?

    @coastaldata

    I’m with hostgator as well. They must have changed it for all my sites because I only told them one but it works fine on my other sites as well now too.

    CoastalData
    Member

    @coastaldata

    Yep, they just wrote me back:

    I’ve gone ahead and disabled it on all of our servers. Please let me know if you are still seeing problems on any of your sites. If there is a custom php.ini file, the following line needs to be commented out or removed.

    extension=oauth.so

    So, no more problems!

    yes i am with host gator also and it is now working, what ever has been done resulting from these comments in the forum has worked for me, hope everyone else gets fixed quick. who ever you are that has addressed and fixed the issue, well done! we like using this plugin and want to support the work of the founder in his ongoing career through good will, i am sure many of us will agree.

    h.lietz
    Member

    @hlietz-1

    Today it just works … Yesterday it didn’t. No changes made. Voodoo?

Viewing 15 replies - 1 through 15 (of 45 total)
  • The topic ‘[Plugin: Twitter Tools] new v2.4 broken/problems?’ is closed to new replies.