WordPress.org

Support

Support » Plugins and Hacks » Twitter Tools » [Plugin: Twitter Tools] Depreciated calls are used (out dated since WP 2.0)

[Plugin: Twitter Tools] Depreciated calls are used (out dated since WP 2.0)

  • Twitter tools code would appear to need to be updated.

    I used the log depreciated notices plugin: http://wordpress.org/extend/plugins/log-deprecated-notices/

    and it says:

    Function: register_sidebar_widget()
    Used in wp-content/plugins/twitter-tools/twitter-tools.php on line 952.

    Use wp_register_sidebar_widget() instead.
    Deprecated in version 2.8.

    and

    Function: register_widget_control()
    Used in wp-content/plugins/twitter-tools/twitter-tools.php on line 980.

    Use wp_register_widget_control() instead.
    Deprecated in version 2.8.

    and

    Argument in add_options_page()
    Used in wp-content/plugins/twitter-tools/twitter-tools.php on line 2071.

    Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead.
    Deprecated in version 2.0.

    And finally

    Argument in add_submenu_page()
    Used in wp-content/plugins/twitter-tools/twitter-tools.php on line 2081.

    Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead.
    Deprecated in version 2.0.

    It seems that some of these things should be pretty simple others maybe not… if the plugin is no-longer supported please mark that in the change-log or on the front page so that potential users know what to expect.

    http://wordpress.org/extend/plugins/twitter-tools/

  • The topic ‘[Plugin: Twitter Tools] Depreciated calls are used (out dated since WP 2.0)’ is closed to new replies.
Skip to toolbar