WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Twitter Tools] can't seem to get it to work

[Plugin: Twitter Tools] can't seem to get it to work

  • I’ve done all the required steps in Twitter Dev tools to set my blog up as an app to use Twitter tools. When I post it’s still not sending my posts to Twitter. I made the access level read-write, inserted the consumer key and secret, and access token and access token secret, and updated the plugin settings. Still nothing. I consider myself an advanced WordPress user who knows code very well. What am I missing here?

Viewing 15 replies - 1 through 15 (of 31 total)
  • same here… when I upgraded to version 2.4, latest tweets didn’t show up (remains the last tweet before upgrade)…

    I have found that if you send a Tweet from the blog backend interface before publishing your post, it will then tweet it.

    Backwards, but it seems it needs that extra authentication sent before it will read again. Really hope the devs get back into it and fix this one issue. I know it is most likely the new oAuth from Twitter causing the issues.

    Sivanesh

    @sivanesh

    the error seems to be because of wordpress 3.0.1

    wphelpcenter

    @wphelpcenter

    Sivanesh — Twitter Tools 2.4 is working fine on 3.0.1

    Spidermann — That’s interesting, we’ll keep that in mind when testing to see if it can lead us to a bug.

    aban – Have you tried the Reset Tweet Checking button located under Settings -> Twitter Tools?

    The plugin is NOT working. It shows my recent posts in the sidebar, but that is it. If I try to make a tweet from the backend or from the sidebar, I get this error: “Oops, your tweet was not posted. Please check your blog is connected to Twitter and Twitter is up and running happily.”

    I am connected to twitter and it is up and running ‘happily’.

    I loved the idea of having it say the tweet came from my own ‘app’, but if it won’t work, then there is no point in me keeping this plugin when there are others out there that will work, despite not having that lil feature. :/

    please fix.

    could this be due to the new rules Twitter has enacted for apps?

    I’d definitely think so

    This plugin has worked perfectly for me for a long time now, it quit after the upgrade that was made for that purpose

    Yeah, Twitter just set a new rule so that all apps must use OAuth, etc. I don’t know what the plugin uses. All I know is that I have the most recent version of WordPress and this plugin and the plugin is not working. So it looks like the dev needs to make an update to the plugin soon to keep users.

    The plugin just had an update to work wit the new twitter rules.

    It’s working for some people.

    It half works for me. I can post to twitter from sidebar. And My new posts go to twitter.

    But nothing comes in. No tweets are getting pulled into my database since the upgrade.

    So yeah, it definitely looks like it has some kinks to be ironed out

    I too am having problems with the tweets coming in and showing in the sidebar. They were showing. I deleted a test tweet I made via twitter itself and that deleted tweet still shows in my sidebar. I did go into the settings and told it to refresh the tweets, etc…..still shows the deleted tweet.

    Yup…something is blocking the database from getting any updates from twitter

    morrisondon

    @morrisondon

    Like others here, I followed all the steps to use OAuth, but disappointingly, TwitterTools no longer works.

    When I click on “Connect to Twitter” on the TwitterTools Options page, I get this error meessage:

    Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or ‘}’ in /content/StartupHostPlus/i/t/it4arts.org.uk/web/WP/wp-content/plugins/twitter-tools/twitteroauth.php on line 19

    arwen54

    @arwen54

    okay, I didn’t want to give up on this great plugin so I’ll tell you what I did. Initially when I set the app up I only gave it read access and when I updated it to read-write access I didn’t know that I needed to generate a new consumer key and secret and a new access token and secret. So today I deleted the app and started over and I’m pleased to report that Twitter Tools now works perfectly!

    So for those of you having trouble…start all over again…make sure you assign read-write access to it!

    Just wanted to state that version 2.4 works fine in my blog running version 3.0.1. I simply followed the directions provided to get OAuth working.

    I was using the old Twitter PHP API for some other scripts on my website and I had to change those over to the newer OAuth method as well. Apparently August 31st was the cut-off date for the older method to still work.

    brianpurkiss

    @brianpurkiss

    When I click on “Connect to Twitter” I get this error

    Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or ‘}’ in /homepages/29/d293799614/htdocs/boldperspective/tweets/wp-content/plugins/twitter-tools/twitteroauth.php on line 19

Viewing 15 replies - 1 through 15 (of 31 total)
  • The topic ‘[Plugin: Twitter Tools] can't seem to get it to work’ is closed to new replies.