Support » Plugins » [Plugin: Twitter Tools] Cant login with it

Viewing 11 replies - 1 through 11 (of 11 total)
  • Same problem here, I even changed the password to make sure but its still not working.

    Though I believe this could be a problem with wordpress 2.9.2 more than twitter tools since another plugin twitter updater is also not working with the same id.

    Regards

    Have you tested your login info on the Twitter Tools settings page? Does it say it was successful there?

    I have the same problem. It worked fine and then just stopped working. Could not sign in from the Twitter Tools settings page. Is there a conflict with anther plug-in?

    I’ve been having this same problem on one of my sites. The strange thing is, the plugin accepts another Twitter account. So it works with one but not the other. Weird. I’m on version 2.9.2 of WordPress and version 2.3.1 of the plugin.

    Same problem here, performing the test login option under the setting returns the oh so help full message of, “Sorry, login failed. Error message from Twitter:” Notice the missing error message.

    The last date that this worked for me was 26th April 2010, the 5 posts I have made since then have not been published to Twitter.

    I see in my Twitter account settings that there is now a section called “connections”, and I have the 3rd party Android app that I use listed in there. Anyone think that Twitter have changed the way that they authorise API connections? Or that a red-herrin?

    Still having this issue here…my recent tweets don’t post to twitter, and it seems to be that Twitter Tools cannot log in. On the settings page it fails with no error message from Twitter, like the poster above.

    Mine is also broken. Resetting my Twitter password, and updating it in the Twitter Tool plugin still does not work. I still get “Sorry, login failed. Error message from Twitter”

    It used to work. It broke before I upgraded WordPress to 3.0.

    Hi,

    Every so often I’ll come back to try this plugin, but to date it’s never been able to log into my twitter account.

    “Post To Twitter” plugin never has problems logging into my twitter account, but it does not has as many features as “Twitter Tools.”

    Hopefully the coders can fix this issue.

    I found the login error. The twitter server is denying access because the user-agent is set to Twitter Tools. I have no idea if twitter server is denying certain people based on IP & user-agent. It’s obviously a twitter issue because the twitter server is responding with a 401 Unauthorized error. As far as I know I’m in good standing with twitter. No problems with twitter at all.

    How to fix the “Twitter Tools” login issue:

    1. Go to admin “Plugins” and click on “Editor”
    2. Edit the file: twitter-tools/twitter-tools.php
    3. Search for: function aktt_login_test
    4. Change the variable, $snoop->agent, to this or whatever agent you want –>

    $snoop->agent = ‘Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6’;

    There’s no line break in the above code.

    I hope that helps.

    Did not work for me.
    Error is blank. How to see?

    You don’t want to return $results->error

    If you want to see the error that twitter is sending back, then return $snoop->response_code

    You probably have another issue.

    I just did the fix on another website and it worked.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Plugin: Twitter Tools] Cant login with it’ is closed to new replies.