WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Twitter Tools] blank page

[Plugin: Twitter Tools] blank page

  • edsu
    Member

    @edsu

    After filling in the key information on the settings page I see a blank page. There doesn’t seem to be a relevant error in the apache logs.

Viewing 14 replies - 1 through 14 (of 14 total)
  • wphelpcenter
    Member

    @wphelpcenter

    Mostly when we have encountered this error it is due to the host running PHP4 instead of PHP5.

    I would suggest checking to make sure all your PHP files are processed with PHP5 and if that doesn’t remove the problem then work with your host to see if they can either increase error reporting so it will be caught in the log, or if they can help you identify the entry in the error log that points to the problem.

    lemonz
    Member

    @lemonz

    I’m having the same problem. Error log reads:

    PHP Parse error: parse error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /home/xyz/xyz.com/html/_word_press/wp-content/plugins/twitter-tools/twitteroauth.php on line 19, referer: http://www.xyz.com/_word_press/wp-admin/options-general.php?page=twitter-tools.php

    wphelpcenter
    Member

    @wphelpcenter

    @lemonz — That error indicates that it is an issue of PHP files being served with PHP4. I would suggest working with your host to make it so all your PHP files are being processed with PHP5.

    Hi!

    I get the above problems after having configured Twitter Tools. I fill in all details on keys etc and press “Connect to twitter”. It tries to take me to mydomain.com/wp-admin/options-general.php but only a blank white page shows up. I have activated all Twitter Tools Extensions installed automatically.

    My PHP version is showing up as:
    PHP 5.2.6-3ubuntu4.6 with Suhosin-Patch 0.9.6.2 (cli) (built: Sep 16 2010 19:52:51)

    Activated extensions are:
    * Akismet
    * Gd STar Rating
    * Google Analytics for WordPress
    * Maintenance Mode
    * ShareThis
    * Si CAPTCHA Anti-spam
    * Twitter Tools
    * Twitter Tools – Bit.ly URLs
    * Twitter Tools – Exclude Category
    * Twitter Tools Hashtags

    I think I had a similar problem to yours until I installed the cURL extension for PHP. I’m on Ubuntu so I just did a:


    aptitude install php5-curl

    and everything worked fine. I imagine you can install with pear or something as well. I emailed the authors of twitter-tools letting them know of the undocumented dependency but they never got back to me. Shrug.

    Hello!
    I’m using PHP4 Version: 4.3.9 and also got this error.
    Previous version of TT worked FINE.

    please, add PHP4 support, my hoster refuses upgrade2PHP5 🙁

    Thank you so very much, edsu!!

    It solved my problems. I had installed curl through “apt-get install curl” but not “apt-get install php5-curl”. Now it all is working fine and dandy! 🙂 Have a nice day!

    Kind regards
    Michael

    Awesome 🙂

    I had the same problem. In a variation of @edsu‘s suggestion: I was able to just uncomment the

    extension=php_curl.dll

    line in the php.ini on my Windows server and restart Apache. Bob’s your uncle: it now works!

    geekiestuff
    Member

    @geekiestuff

    Hello….

    My problem is a little different with Twitter Tools. After successfully installing Twitter Tools, I can no longer login to my Admin account nor can I go to my site using the url. The only thing that appears is a blank white page. Any ideas?

    P.S. Same issue with hosting account…

    geekiestuff
    Member

    @geekiestuff

    Forget about my previous post….working fine now.

    I just moved to a new ubuntu server and it was the php5-curl problem. CHeck this one out then bounce apache and it should be ok.

    geekiestuff
    Member

    @geekiestuff

    Thanks rjharv,

    Working fine now….thanks.

    Created a forum account just to thank @edsu

    Fixed it with:
    aptitude install php5-curl

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Plugin: Twitter Tools] blank page’ is closed to new replies.