WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Twitter for WordPress] No public Twitter messages

[Plugin: Twitter for WordPress] No public Twitter messages

  • I get a lot of:

    No public Twitter messages

    on my site. No all the times though.

    And trust me there are public Twitter messages on my twitter (they all are)

Viewing 15 replies - 16 through 30 (of 59 total)
  • @bmharris

    that didnt do it for me.

    the 1.9.4 upgrade fixes the issue

    I am using 1.9.4 and am still experiencing this. I’ve tried the other fixes noted above to no avail. The plugin works for a while, then it doesn’t and displays “No public Twitter messages.” Anyone else have any insight?

    the “158” fix worked for me (altough it seemed more line 160 in 1.9.4)
    by commenting the line the tweets started again…

    All this on a wp 2.6.3 heavily modded. I hope this might help 🙂

    I deleted line No. 160 in 2.7 and it doesn’t fix the problem.
    I need to correct it.

    I’ve successfully devised a function that has reliably grabbed the latest Tweet for the last several days for me.

    For those of you who have been getting this problem and want a no-frills function that grabs only the most recent tweet, you can find the function here.

    It uses the Atom feed instead of RSS. My server has had no problems with it.

    I think it clearly has something to do with the MAGPIE_CACHE feature.

    When the cache expires (by default, 180 seconds), the plugin works, otherwise it does not retrieve the feed. In fact, I think that magpie is not able to write the cache file, so it doesn’t return anything.

    I’m trying to define another MAGPIE_CACHE_DIR to see if it has anything to do with permissions, but I’m still failing.

    I have a question does this plugin just add feeds from your twitter account to your blog or does it also take posts from your blog and feed them into twitter. If it does not post your blog post in twitter then is there a plugin that does this?

    @amthomas: http://www.twitterfeed.com will do what you want.

    I think I found a solution to this problem.

    If you edit the ‘twitter-for-wordpress/twitter.php’ in line 54 (think that was the line) to

    $messages = fetch_rss('http://twitter.com/statuses/user_timeline/yourtwittername.rss');

    everything should work just fine…
    at least it does for me.

    NOT, sorry people

    I’m using 1.9.6 and WP 2.8.1 and I still get the error from time to time.

    It was playing up for me too (displaying tweets from November last year!) but I just upgraded to WP 2.8.2 and it’s working…

    And almost an hour later it’s still okay.

    Might just need to upgrade WP guys. 😀

    I use WP 2.8.1 and everything works fine.

Viewing 15 replies - 16 through 30 (of 59 total)
  • The topic ‘[Plugin: Twitter for WordPress] No public Twitter messages’ is closed to new replies.