WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Twitter Embed] No tweet displayed

[Resolved] [Plugin: Twitter Embed] No tweet displayed

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Konstantin Kovshenin

    @kovshenin

    Anointed, you can start by turning on debug mode, that will produce a better error message when a tweet cannot be fetched. It could happen for several reasons, the Twitter API might be down, or you might be fetching a protected tweet, etc. Let me know if debug mode reveals anything. Thanks!

    Same issue here. Turned on debug and saw this:
    Notice: Undefined property: stdClass::$html in .../wp-content/plugins/twitter-embed/twitter-embed.php on line 97

    The links are properly inserted.

    Thoughts?

    Plugin Author Konstantin Kovshenin

    @kovshenin

    @thecorkboard, thanks for reporting this, can you say which tweet are you trying to embed?

    Weirdly, I disabled and re-enabled the plugin and they all show up fine now.

    Plugin Author Konstantin Kovshenin

    @kovshenin

    Could have been a temporary issue with the Twitter API…

    Well, I have it too. No idea why. I don’t think it has to do with which tweet. I also deactivated and activated, but that doesn’t do anything either.

    Any suggestions?

    Thanks in advance, Tom

    Plugin Author Konstantin Kovshenin

    @kovshenin

    Hi Tom, thanks for reporting this. Do you get any error message with WP_DEBUG turned on in wp-config.php?

    Yep, I got a warning that HAS_CAP is no longer used. Interestingly, when I turned debug on, it suddenly worked. Then I switched it off, and it continues to work. Beats me! 🙂

    This goes for both your Twitter embed plugins.

    martinhult

    @martinhult

    I got the exact same problem, debug error:

    Notice: Undefined property: stdClass::$html in /customers/_3/5/0/martinhult.com/httpd.www/wp-content/plugins/twitter-embed/twitter-embed.php on line 97

    Turning the plugin on/off didn’t work neither did launching debug mode.

    Anointed

    @anointed

    Is there a solution to this problem being worked on?

    Plugin Author Konstantin Kovshenin

    @kovshenin

    Should be fixed in 1.1. Please open a new support request if it’s not.

    The update broke my embedded Tweets. It just shows the Twitter URL now.

    Plugin Author Konstantin Kovshenin

    @kovshenin

    @wpbk: please send me an e-mail with the URL of your blog and a few example pages where the embeds stopped working. My address is kovshenin at gmail dot com. Thanks!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Resolved] [Plugin: Twitter Embed] No tweet displayed’ is closed to new replies.