Support » Plugins » [Plugin: Tweetblender] 404 message in history

  • gsibert

    (@gsibert)


    I recently installed tweetblender and also use the wassup plugin which shows page history of visitors. Since installing tweetblender, I get this from numerous visitors in the history log:

    [404] /wp-content/plugins/tweet-blender/ws.php?action=cache_data

    Any thoughts, ideas?

Viewing 13 replies - 1 through 13 (of 13 total)
  • gsibert

    (@gsibert)

    oops, forgot to put my site link:
    http://www.3smanagement.com

    kirilln

    (@kirilln)

    @gsibert,
    Checked out your site and am not sure how this could be generating a 404. The ws.php script is definitely there and working, the URL is correct.

    Can you match the error log to access log (by IP/timestamp) to get more context? It could be a browser- or os-specific issue that doesn’t come up for my test set.

    gsibert

    (@gsibert)

    I just tweeted a screen shot w/ @tweetblender I think you may be the top entry & if everything worked for you I’m not worried about the error msg on my side.

    gsibert

    (@gsibert)

    Not sure why I tweeted that instead of a DM… Anyway, here’s the link to the image.

    gsibert

    (@gsibert)

    kirilln

    (@kirilln)

    Ok, I’ll check it out in IE7 on Win

    @saranda: Thanks!

    I have the same problem
    [404] /wp-content/plugins/tweet-blender/ws.php?action=cache_data
    16:03:00 ->[404] /wp-content/plugins/tweet-blender/ws.php?action=cache_data
    16:07:21 ->[404] /wp-content/plugins/tweet-blender/ws.php?action=cache_data

    My blogg is at http://www.bahlool.se

    Same problem. Infact, it started taking up heavy server resources! So, I had to remove the plugin. Been almost 3 weeks since I removed the plugin. Yet, it shows up in my error logs on a certain page only –
    URL (xxx) Error Hits Referrers
    /wp-content/plugins/tweet-blender/ws.php 65149 http://www.pentestit.com/2010/03/22/toolza-sql-injection-tool-options/

    Don’t know why this keeps happening.

    This plugin caused my website being down for almost 6 hours.

    Right after i install Tweetblender my server stopped responding. Couple hours later my hosting company sent me a notification that they suspended my website because of this plugin causing the whole server stop working. So i went through phpmyadmin and delete the plugin and then everything went back to the normal. Even-though i remove the plugin i am still seeing few action=cache_data in my error logs.

    @senols: Tweet Blender caches tweets by using a centralized cache system that is maintained by ALL visitors to your site. This allows visitors that reached their Twitter API limit to still get fresh tweets because other visitors update the cache for them.

    Each widget sends a cache update request from the browser. If user opened your site with the widget on it and never closed that browser window the widget will keep refreshing and trying to update cache. If you delete the plugin the browser would still keep trying and you’ll see the 404s you are seeing. Until that browser window is closed or page is refreshed without the widget in it you will still see cache update requests.

    If you have a high traffic site, use many different widgets with different settings, or put in many sources in tweet blender then the cache update requests will be more frequent and can overload your server. You can:
    1) turn off caching completely by going to WP Admin > Settings > Tweet Blender > Archive tab
    2) Increase your widget refresh rates so they refresh less frequently
    3) Use less individual sources e.g. create a twitter list, add all users you’d like to include in your stream to that list, and then use that list as the only source for the widget.

    P.S. If your website’s uptime is important I recommend you test the plugins in a test environment before putting them on the live site.

    @kirilln Thank you for the response and thanks for the plugin. I guess i did it wrong when i turned on caching option. But now everything is fine. Thanks again.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Plugin: Tweetblender] 404 message in history’ is closed to new replies.