Revive Old Post (Former Tweet Old Post)
[resolved] [Plugin: Tweet Old Post] API Error Message When Authenticating (6 posts)

  1. dmahler
    Posted 4 years ago #

    Here's what I'm getting in all the different browsers:


    Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

    Nothing but a "This page cannot be displayed" once it authenticates on Twitter and tries to redirect back to the blog.

    The webpage at https://api.twitter.com/login?redirect_after_login=%2Foauth%2F%26TOP_oauth%3D1%3Foauth_token.....
    has resulted in too many redirects. Clearing your cookies for this site or allowing third-party cookies may fix the problem. If not, it is possibly a server configuration issue and not a problem with your computer.
    Error 310 (net::ERR_TOO_MANY_REDIRECTS): There were too many redirects.

    Too many redirects occurred trying to open https://api.twitter.com/oauth/&TOP_oauth=1?oauthtoken........
    This might occur if you open a page that is redirected to open another page which then is redirected back to the original page.

    Would really like to use this!


  2. articlescholar
    Posted 4 years ago #

    I am having the same problem, I tried to change the twitter account in use then it's now throwing me the same authentication error.

  3. Ajay Matharu
    Posted 4 years ago #

    Guys checkout the FAQ for too many redirects issue. Let me know if you still face the issue after following those steps in FAQ.

  4. dmahler
    Posted 4 years ago #

    That was bizarre! I don't understand why it worked but it did.

    I made sure the page was showing the right URL in the TweetOld Posts settings page and did the "save" again as it suggested. Bang! It authenticated.

    I don't understand why it worked, but it did. Thank you!

  5. dartiss
    Posted 4 years ago #

    This worked for me too. Simply saving the options - even though I hadn't changed them - resolved the authorisation issue.


  6. Ajay Matharu
    Posted 4 years ago #

    :) that was because the plugin had to send the return url to twitter after authenticating which was not happening coz of various tweaks one can have on url e.g. changed permalink so had to go this way.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic