Support » Plugin: Simple Lightbox » Plugin trys to access none existing Path

  • Resolved viosys

    (@viosys)


    When we have your Plugin activ our Site throws following Warning Message:

    Warning: is_dir(): open_basedir restriction in effect. File(/var/www/clients/client35/web199/web/public/wp-content/plugins/simple-lightbox/controller.php/l10n) is not within the allowed path(s): (/var/www/clients/client35/web199/web:/var/www/clients/client35/web199/private:/var/www/clients/client35/web199/tmp:/var/www/socialgambiawp.projektbereich.info/web:/srv/www/socialgambiawp.projektbereich.info/web:/usr/share/php5:/usr/share/php:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/etc/ssl/certs:/dev/urandom)
    
      at /var/www/clients/client35/web199/web/public/wp-content/plugins/simple-lightbox/includes/class.base.php:172
      at SLB_Base->_env()
         (/var/www/clients/client35/web199/web/public/wp-content/plugins/simple-lightbox/includes/class.base.php:143)
      at SLB_Base->_init()
         (/var/www/clients/client35/web199/web/public/wp-content/plugins/simple-lightbox/controller.php:167)
      at SLB_Lightbox->_init()
         (/var/www/clients/client35/web199/web/public/wp-content/plugins/simple-lightbox/includes/class.base.php:121)
      at SLB_Base->__construct()
         (/var/www/clients/client35/web199/web/public/wp-content/plugins/simple-lightbox/controller.php:155)
      at SLB_Lightbox->__construct()
         (/var/www/clients/client35/web199/web/public/wp-content/plugins/simple-lightbox/load.php:37)
      at require_once('/var/www/clients/client35/web199/web/public/wp-content/plugins/simple-lightbox/load.php')
         (/var/www/clients/client35/web199/web/public/wp-content/plugins/simple-lightbox/main.php:43)
      at slb_init()
         (/var/www/clients/client35/web199/web/public/wp/wp-includes/class-wp-hook.php:303)
      at WP_Hook->apply_filters()
         (/var/www/clients/client35/web199/web/public/wp/wp-includes/class-wp-hook.php:327)
      at WP_Hook->do_action()
         (/var/www/clients/client35/web199/web/public/wp/wp-includes/plugin.php:470)
      at do_action()
         (/var/www/clients/client35/web199/web/public/wp/wp-settings.php:578)
      at require_once('/var/www/clients/client35/web199/web/public/wp/wp-settings.php')
         (/var/www/clients/client35/web199/web/public/wp-config.php:36)
      at require_once('/var/www/clients/client35/web199/web/public/wp-config.php')
         (/var/www/clients/client35/web199/web/public/wp/wp-load.php:55)
      at require_once('/var/www/clients/client35/web199/web/public/wp/wp-load.php')
         (/var/www/clients/client35/web199/web/public/wp/wp-blog-header.php:13)
      at require('/var/www/clients/client35/web199/web/public/wp/wp-blog-header.php')
         (/var/www/clients/client35/web199/web/public/index.php:17)

    The Plugin trys to Check if the path /var/www/clients/client35/web199/web/public/wp-content/plugins/simple-lightbox/<strong>controller.php/l10n</strong> is a directory. There cant be a directory at this Path tho since it is looking inside of the controller.php file. The real path to the l10n directory is /var/www/clients/client35/web199/web/public/wp-content/plugins/simple-lightbox/l10n.

    WordPress Version: 5.8.3
    Plugin version: 2.8.1
    Other Plugins:

    • Adminimize
    • Autoptimize
    • Better Search Replace
    • Duplicate Page
    • iThemes Security
    • User Role Editor
    • WP PGP Encrypted Emails
    • WPForms Lite
    • YoastSEO
    • This topic was modified 6 months, 2 weeks ago by viosys. Reason: added tag warning

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Archetyped

    (@archetyped)

    Hi, this behavior is not reproducible on a standard WordPress installation, so this warning may be related to your server’s particular settings.

    Looking at the paths in your site’s open_basedir setting, there may be a mismatch between the file paths that the server/PHP is seeing and what WordPress is seeing. This can occur if you are using symbolic links to serve the site’s code from a different path.

    You can confirm whether this is the issue by checking the value of WordPress’ WP_PLUGIN_DIR constant. Based on the paths in the message, WP_PLUGIN_DIR‘s value should be /var/www/clients/client35/web199/web/public/wp-content/plugins. If the path is different, then updating the site’s settings so the base file paths match is recommended, as mismatched paths can cause issues throughout WordPress.

    If the base paths match, then here are other things to evaluate:

    Your site’s specific open_basedir property (noted at the start of the warning) may be affecting the normal behavior of PHP’s file/directory functions used in SLB.

    Temporarily disabling the custom open_basedir property is recommended to determine if that resolves the issue.

    Also, the link you provided is not accessible due to an HTTP authentication login being required. As noted in SLB’s requirements documentation HTTP authentication can block the loading of files and prevent SLB from functioning properly.

    Disabling the HTTP authentication is recommended to determine if that resolves the issue.

    If you are still experiencing an issue after following the above recommendations, there may be a conflict with another plugin or the site’s theme. Here are instructions for identifying plugin/theme conflicts.

    Please let know what you find from the above steps. If you are still experiencing an issue, please provide an updated link that is accessible so that the issue can be fully evaluated.

    Please also provide the following details:

    • WP_PLUGIN_DIR value
    • PHP Version
    • Server name and version (e.g. Apache, NGINX, etc.)

    Thank you.

    Plugin Author Archetyped

    (@archetyped)

    Hi, are you still experiencing an issue with SLB? If so, please provide the previously-requested details and I would be glad to take a look.

    This ticket will be closed in 24 hours due to inactivity.

    Plugin Author Archetyped

    (@archetyped)

    This ticket has been closed due to inactivity.

    Thread Starter viosys

    (@viosys)

    Very Sorry for the late reply.

    Php Version: PHP 7.4.27
    WP_PLUGIN_DIR:/var/www/socialgambiawp.projektbereich.info/web/public/wp-content/plugins/
    Server: nginx/1.21.5
    htaccess: i would send u an email with the login data although i could not find your email anywhere

    Temporarily disabling the custom open_basedir property did infact help.Although it would be nice to be able to have to Plugin not throw a Warning and for open_basedir to be enabled at the same time. Since restricting the ability for 1 project to access files outside its own file structure is rather nice.
    Do you have any Idee on how to achive this?

    Many Thanks in advance and again sorry for the late reply.

    • This reply was modified 5 months, 3 weeks ago by viosys.
    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Rep

    @viosys Please don’t offer to send or post logon credentials on these forums:

    https://wordpress.org/support/guidelines#the-bad-stuff

    Plugin Author Archetyped

    (@archetyped)

    Hi, thank you for confirming that the site’s WP_PLUGIN_DIR path does not match the path the site is being served. As noted in my previous reply:

    If the path is different, then updating the site’s settings so the base file paths match is recommended, as mismatched paths can cause issues throughout WordPress.

    Updating the base ABSPATH constant in the site’s wp-config.php file (documentation) to match may resolve the mismatch as many of WordPress’ path constants are based off that value. However, testing is recommended after making any changes to ensure there are no other issues due to your site’s non-standard configuration.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.