Support » Plugin: Transposh WordPress Translation » [Plugin: Transposh WordPress Translation] WordPress 3.4.2 and Transposh 0.8.4 not working?

Viewing 4 replies - 1 through 4 (of 4 total)
  • ChemaZ


    You probably should give more details of what’s happening and what’s not with your site fregad.

    It’s possible we have a similar problem, though I am still in WP 3.4.1: Transposh no longer translates my pages; I can still see my translation history, I can make new translations –and they work momentarily, the pink icon turns green and they are added to the database; but as soon as I reload the page/turn off editing, the text reverts to the default language.

    I’ve tried completely wiping plugin and it’s entries in my database (dropping translations, translations_log and the three Transposh tuples from options) and reinstalling, with no luck.



    Still need help but have found out some more info I think.

    I got a reply from Transposh’s founder to check the compliance with “w3c” which I did.
    Correctly there is an error (actually two but seems like the second one depends on the first) in the output of source code. A </style> is printed out after the html and body close tags!!!

    <script type="text/javascript">
    var load_cmc = function(){linktracker_init(39332515,6,2);};
    if ( typeof addLoadEvent != 'undefined' ) addLoadEvent(load_cmc);
    else load_cmc();
    <meta name="translation-stats" content='{"total_phrases":null,"translated_phrases":null,"human_translated_phrases":null,"hidden_phrases":null,"hidden_translated_phrases":null,"hidden_translateable_phrases":null,"meta_phrases":null,"meta_translated_phrases":null,"time":"0.021"}'/>
    <!-- Dynamic page generated in 0.723 seconds. -->
    <!-- Cached page generated by WP-Super-Cache on 2012-09-12 06:10:22 -->
    <!-- super cache -->

    The problem remains since I have no clue whatsoever to what puts the code there…

    I have checked the index.php, header.php, functions.php, footer.php and many more and can not find any answer.
    I have tried to disable ever plugin (since I found somewhere that it had helped for somone with the same problem) without success.

    Very frustrating!!! I am out of ideas here So any help or hints would be VERY helpful!

    Thanks in advance!



    That style tag is weird indeed, though being a closing tag it doesn’t affects your page at all, and I don’t see how such a markup error could prevent Transposh from doing its job.

    So at first sight, I would think that error is unrelated… *except* there’s a Transposh meta declaration right after it, which should be on the head. So perhaps there’s something wrong with your template’s header.php, or some other part. Particularly, check that your header.php has a <?php wp_head(); ?> right before </head>, and similarly, that footer.php has <?php wp_footer(); ?> before </body>.

    You already tried disabling all the other plugins, but how about switching your theme (for the defaul 2011 for example)? As a last resort, you can get a local copy of your files, and do a recursive grep for ‘</style>’ in your wordpress/wp-content directory to find all the possible sources (any decent text editor can do it), or even do a mass replacement to try to find the culprit automatically, doing something like:

    find . -regex '.*\.\(html\|php\)$' | xargs perl -pi -e 's{</style>}{</style><!-- DELME $ARGV -->}ig'

    in Linux, reloading your site, and checking which filename is next to the astray style tag, then reverting the changes with:

    find . -regex '.*\.\(html\|php\)$' | xargs perl -pi -e 's{<!-- DELME .*? -->}{}ig'

    Of course, you should do any experimentation in a copy of your site, and have a backup ready.

    Funny thing is, for me Transposh works perfect in my local test site, but I can’t get it to function again on my production server. Sometimes Murphy is just a bully. >.<



    Thanks a bunch ChemaZ!

    I solved it by upgrading the theme. (Suffusion which I by the way STRONGLY can recommend. Extremely flexible and free 😉 )

    Still annoying to not understand where it came from. 🙁


Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: Transposh WordPress Translation] WordPress 3.4.2 and Transposh 0.8.4 not working?’ is closed to new replies.