Support » Plugin: Transposh WordPress Translation » [Plugin: Transposh WordPress Translation] Translations only shown if I "fix database errors&quo

  • Resolved ChemaZ

    (@chemaz)


    Hi,

    Transposh works wonderfully in my PC, but not so with my hosting provider. There, when I translate something, the text changes, tuple is added to wp_translations, everything looks alright; until I reload the page, then the translation is not shown anymore. This is a fresh WordPress 3.4.2 install (I also tested with 3.4.1) and Transposh 0.8.5:

    http://goo.gl/9YfLC

    If you click on translate “Pozdravljen svet” (Hellow world, the title), for example, you can see it’s already translated in the history, and if you translate it again, the english text will disappear as soon as you reload the page.

    All the translations do appear when I “fix errors by previous versions”, however. But I can’t ask my users to do that after every translation, of course.

    I see that db_maint recreates Transposh’s relations, eliminates dupes and also clears the cache several times with cache_clean and cache_delete. wp_translations looks just fine:

    To je vaš prvi prispevek	en	This is your first post	0
    Dobrodošli v WordPress	en	Welcome to WordPress	0
    Neuvrščeni	en	Unlisted	0
    Vzorčna Stran	en	Sample Page	0
    Dobrodošli v WordPress	hr	Dobrodošli na WordPress	0

    so it’s probably a caching issue. It’s a fresh install, however, and I didn’t had any caching engine. I just installed WP Super Cache to see if it changed anything, but it didn’t. I’d really like to get Transposh working. Do you have any suggestions?

    Thanks in advance.

    http://wordpress.org/extend/plugins/transposh-translation-filter-for-wordpress/

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author Ofer Wald

    (@oferwald)

    Hello Again 😉

    Looks like a caching issue, I totally agree, can you disable supercache? so I can look at what happens without this added layer of complexity?

    Also, do you have apc/xcache/whatever on your server? can you use the constants.php file and disable caching altogether?

    Good luck

    Super Cache disabled. The server runs XCache 1.3.1 and memcached 1.4.10, but being shared hosting I’m afraid I can’t turn them off.

    I see Transposh supports both of them, but could there be a problem from having both simultaneously? I’m not familiar with the inner workings of caching, though perhaps it’s about time…

    If you’d be so generous with your time and want admin access, just let me know. 😉

    Oh, options.php is Transposh’s! Disabling caching eliminates the problem instantly, all the missing translations appear and new ones show up without having to “fix database errors.” So I will re-enable it to troubleshoot the problem.

    Plugin Author Ofer Wald

    (@oferwald)

    I guess it is an xcache issue, when the site has no self memory (shared environment). I have limited visibility of the problem, but will probably have better in the coming version of Transposh.

    For now, just disable the caching.

    If you see anything on your error logs, let me know.

    Alright, I will do that.

    One last thing: the FAQ states that I can “mark a post with a language … with a select box that appears below the post”, but for the life of me I can’t find it. Does it shows in a box like Custom Fields? Do I have to do something to enable it?

    Thanks again!

    Plugin Author Ofer Wald

    (@oferwald)

    Try the screen options at the top of the post, maybe it is not selected… 🙂

    I did check those, of course. I’m not *that* new at WordPress. 😉

    Looking at the code, I see it only appears when “automatic translation after posting” is enabled, as per if ($this->transposh->options->get_enable_auto_post_translate()) in transposh_postpublish.php.

    I made a patch to make it always appear without a forced machine translation –which I dislike– and submitted it to your trac.

    Plugin Author Ofer Wald

    (@oferwald)

    Wanted to thank you for your submissions to the trac, really appreciated.

    I would like to give you credits on the next version release notes, please contact me via the contact form on my site.

    🙂

    Oh, about those, give me a minute to review them, I ran into problems and reverted them. I haven’t found time to familiarize myself enough with Tranposh’s internals, so it was not a surprise it happened. 😛

    Plugin Author Ofer Wald

    (@oferwald)

    Didn’t used them directly as is 😉 but they were quite good and you deserve that credit

    (argh, system frozen dead, REISUB restart required… not what you want to see on a fresh Kubuntu install! >.<)

    Yes, I reverted transposh_postpublish.langmetabox_always.patch​ since it provoked some nasty problems, and haven’t played more with it. Sorry for the noise, hopefully I’ll get it right in the future as I expect to use Transposh in new projects. Only then we’ll talk about any credit. 🙂

    The z-index patch is good though (it’d better! It’s so small).

    I planned to say this before on your trac, of course, but I couldn’t see “My Tickets.” I thought you had to approve them or something, and then, of course, I forgot all about it. I still can’t see My Tickets though (should I submit a ticket about it? :P), so seems searching is the only way to find them.

    […reads your reply…]

    Oh, if you did fix my broken patch, then I can’t wait for the new version!

    Plugin Author Ofer Wald

    (@oferwald)

    Hi,

    First – use gentoo 🙂 if it gets stuck, than you can blame yourself
    Second – credits, as you wish, I respect that, both patches will make the next version, including the fixed one

    Regarding the tickets, I am sometimes slow in approving stuff and responding, this is better than the occasional spam tickets that made it through, which I am the only one to see now…

    They will be live in the coming days, sorry about that.

    Thanks again, and any further patches are always welcomed

    Oh, Gentoo is on the list, though not nearly the top –that would be Arch. 😉

    I completely understand, so don’t worry. I’m trying to cut down my screen hours myself, though the stern look of Workrave’s sheep somehow has not been too effective so far… 😉

    All I meant to say is that there seems to be a bug in trac (though it’s too big to pass unnoticed): when I go to View Tickets -> My Tickets I get “No matches found.” Going to Active Tickets, Mine first doesn’t shows mine first either. So the only way for me to find my tickets is searching. I only realized this today, and that’s why I had forg^H^H^H^H postponed commenting on my patch. 🙂

    I’ll gladly submit more fixes (thoroughly tested this time!) when I find some rough edges. Cheers!

    Plugin Author Ofer Wald

    (@oferwald)

    Just to let you know that your patches made it through…

    Also – why Arch over Gentoo 🙂 ?

    Neato!

    Arch over Gentoo… because I don’t have to compile everything myself, for starters! 😉 The times where I wanted to do everything by myself are long past; the true men that wrote their own device drivers are near extinct, so I don’t feel too bad. 😉 Nowadays I settle for the path of least resistance…

    I used mostly Debian on my sysadmin years, and it’s hard not to fall in love with its internals (more so coming from the old Red Hats), and specially, its community, for practical and philosophical reasons. Ubuntu is more polished and mainstream (almost everyone packages for it), so it has become the easiest distro, if not for most people, certainly for me –though it sadly lacks all the other virtues of Debian.

    Still, I manage to crash something on daily basis, so I get more bug squash juice than I would like; KDE and Firefox I report directly upstream, but Ubuntu stuff I just don’t bother anymore; as nice as it is, Launchpad is mostly a ghost town.

    So I dream of a highly polished distro with great QA and some hippie flavoring too, with active maintainers and a knowledgeable community. Hey, one can dream! I’m actually happy enough with Ubuntu, have been so for some seven releases. But it’s always good to compare quality and get some variety –unless you’re married, to a distro or otherwise. 😉

    Arch looks more approachable for someone that wants thing to just work, but with a good community to fall back when they don’t. I’m also curious on how different a rolling distro could be from Debian’s testing or unstable branches, as I dislike following a frozen branch more every day (gotta rely on 3rd party backports, upgrades take long and everything that has to break does so simultaneously).

    Gentoo’s community looks pretty strong, but it seems too much work just to squeeze a few extra cycles (maxing my RAM had the biggest impact I could hope for already; though SSDs are quickly approaching us 3rd world mortals).

    Phew, so there; ball’s in your court. Your turn to do a Gentoo pitch. 😉

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘[Plugin: Transposh WordPress Translation] Translations only shown if I "fix database errors&quo’ is closed to new replies.