Support » Plugin: Transposh WordPress Translation » [Plugin: Transposh WordPress Translation] Translation breaks after slideshow

  • Resolved Andrew


    Hi Ofer,
    I’m using transposh on another project and it’s going quite well besides this little error. I’m using a plugin to implement a slideshow Portfolio Slideshow and when using transposh it seems to translate down the DOM until it hits the slideshow and then stops, not translating any further. I’ve tried another slideshow plugin and got the same results.

    You can view it on the development site here.. and to get past the curtain I’m sending you the credentials via your contact form at
    The language toggle is in the top left 🙂

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Ofer Wald


    Hello Andrew,

    I think there’s an issue of some tags not being closed, if a tag is not closed the entire parsing might go bad.

    Please try to make sure the page passes w3c validation (as much as it could)

    Hi Ofer,
    I did see that there were some validation errors and I worked to get the number down to 6 errors rather than 20 or so 🙂 but I still see that these may be responsible, I’ll do my best to root out those issues and let you know how it goes from there.

    Thanks for your response and your time!

    Hi Ofer,
    It seems that the Portfolio slideshow plugin I was using is somehow conflicting with my theme and causing some tags to not be closed. The plugins output seems fine (opening and clossing tags) and the theme itself seem fine as well, but for some reason it’s tripping up somewhere. I can see this isn’t a transposh issue, but is something I can’t quite figure out at the moment.

    But I also have the same issue when using a very popular Map plugin
    MapPress Easy Google Maps and this one doesn’t cause any broken tags in validation, but it still breaks transposh’s translation at the page where the map is embedded. You can see this happening here..

    Again the same credentials I sent you earlier apply to get past the curtain.

    Thank you so much for your time Ofer.

    Plugin Author Ofer Wald


    Hello Andrew,

    It seems like there is some open input tag that might be interfering with the parser, can you make sure it closes (or self closes?)

    Keep me posted

    Hi Ofer, I had a closer look at the source for the page and I can’t find any open <input> tags there are 7 in total and they are all self closed <input/>. Validation is just short of perfect with only 1 error (transposh generated). Any further idea’s?

    I’ve tried another map plugin hoping to just avoid the issue, but it also breaks.

    Plugin Author Ofer Wald



    This is how things appear in the fr version… broken
    <input type=’submit’ class=’mapp-button’ value=’Voir l’>
    <input type=’button’ class=’mapp-button’ value=’Imprimer l’>

    This is how they appear originally…
    <input type=’submit’ class=’mapp-button’ value=’Get Directions’ id=’mapp0_get_directions’ />
    <input type=’button’ class=’mapp-button’ value=’Print Directions’ id=’mapp0_print_directions’ />
    <input type=’button’ class=’mapp-button’ value =’Close’ id=’mapp0_close_directions’ />

    Can you try wrapping the map with a no_translate classed span?

    Strange, so even though the parser was set to not translate HTML entities, perhaps because it is being generated by a shortcode that it still tries to translate the code. Wrapping it in a <span class=”no_translate”></span> works great! I had tried that earlier with the slideshow plugin referred to at the start of this post, but because the error is being produced by unclosed or strangely generated tags, it still didn’t rectify the problem, but for this issue I had forgotten to try it.

    Thanks Ofer. You’re help was really beneficial! Thank you!

    Plugin Author Ofer Wald


    Glad to hear that, finally marking this resolved

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: Transposh WordPress Translation] Translation breaks after slideshow’ is closed to new replies.