Support » Plugin: Transfer » [Plugin: Transfer] Error

  • Hi,
    after installing the transfer plugin including the zend framework (minimal) i get this error message in wordpress when attempting to activate the plugin:

    Warning: require_once(Zend/XmlRpc/Client.php) [function.require-once]: failed to open stream: No such file or directory in /home1/yourmeco/public_html/unibz/debranding/wp-content/plugins/transfer/library/Aperto/XmlRpc.php on line 3

    Fatal error: require_once() [function.require]: Failed opening required ‘Zend/XmlRpc/Client.php’ (include_path=’.:/home1/yourmeco/public_html/unibz/debranding/wp-content/plugins/transfer/library/:.:/usr/lib64/php:/usr/lib/php’) in/home1/yourmeco/public_html/unibz/debranding/wp-content/plugins/transfer/library/Aperto/XmlRpc.php on line 3

    Versions:
    WP 3.0.1
    transfer 1.0.0
    ZendFramework-1.10.8-minimal

    What’s wrong?

    best regards
    Kris ><

Viewing 4 replies - 1 through 4 (of 4 total)
  • Dia Ritoch

    (@dritoch)

    Hi Kris,

    Go to your wp-config and paste this right after * @package WordPress part and before // ** MySQL settings – You can get this info from your web host ** //

    /** Zend Framework **/

    function add_include_path ($path)
    {
    foreach (func_get_args() AS $path)
    {
    if (!file_exists($path) OR (file_exists($path) && filetype($path) !== ‘dir’))
    {
    trigger_error(“Include path ‘{$path}’ not exists”, E_USER_WARNING);
    continue;
    }

    $paths = explode(PATH_SEPARATOR, get_include_path());

    if (array_search($path, $paths) === false)
    array_push($paths, $path);

    set_include_path(implode(PATH_SEPARATOR, $paths));
    }
    }

    add_include_path(dirname(__FILE__).’/wp-content/plugins/zend-framework’);

    Let me know if it worked. Worked for me though.

    Dia

    kkrois

    (@kkrois)

    Hi Dia,
    unfortunately it did not work. Its for sure a path problem, but not exactly that one. I am not really a web devolver, but i I tried more things:
    i put the directory ‘zend-framework’ according to the path of the last line of your code – and the other way around: changing the in the code to ‘wp-content/plugins/transfer/library/zend-framework’

    I keept getting the same kind of error message.

    I also tweaked the path in line 3 in “/plugins/transfer/library/Aperto/XmlRpc.php”: require_once ‘Zend/XmlRpc/Client.php’;

    no success 🙁 Any idea?

    ciao
    K ><

    Hello again,
    i reinstalled everything, i inserted the code in wp-config.php, where i also adapted the directory name in the Zend include_path (from “zend-framework” to “ZendFramework-1.11.0-minimal”. But i keep getting the same error message 🙁 see below).
    What’s wrong?

    ciao
    Kris ><

    Warning: require_once(Zend/XmlRpc/Client.php) [function.require-once]: failed to open stream: No such file or directory in /home1/yourmeco/public_html/unibz/debranding/wp-content/plugins/transfer/library/Aperto/XmlRpc.php on line 3

    Fatal error: require_once() [function.require]: Failed opening required ‘Zend/XmlRpc/Client.php’ (include_path=’.:/home1/yourmeco/public_html/unibz/debranding/wp-content/plugins/transfer/library/:.:/usr/lib64/php:/usr/lib/php:/home1/yourmeco/public_html/unibz/debranding/wp-content/plugins/transfer/library/ZendFramework-1.11.0-minimal’) in /home1/yourmeco/public_html/unibz/debranding/wp-content/plugins/transfer/library/Aperto/XmlRpc.php on line 3


    i also tired to modify the path in “XmlRpc.php” on line 3 (inserting the complete path from root: ‘/home1/yourmeco/public_html/unibz/debranding/wp-content/plugins/transfer/library/ZendFramework-1.11.0-minimal/library/Zend/XmlRpc/Client.php’
    did not help.

    Hi,
    i just just didn’t get it installed 🙁
    What a pitty, the plugin would do exactly what i need. Is the an alternative plugin?
    ciao
    Kris ><

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: Transfer] Error’ is closed to new replies.