Support » Plugin: TP - TweetPress » [Plugin: TP – TweetPress] Twitter not authorizing

  • Resolved katespace


    I’ve entered my consumer key and consumer secret in the TweetPress app area now and am trying to configure the rest of the plugin. However, when I click on “Sign in with Twitter” under automatic publishing, nothing happens; it reloads the page and doesn’t sign me in.

    If I try to log into the wp-admin area of my site, it says “Twitter user not recognized.”


    What should I be entering for the registered callback URL on the @anywhere Settings on Twitter?

    Thanks. 🙂

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Louy Alakkad


    Have you connected your twitter account in your WordPress Profile page?

    Thanks for the reply. I just tried to do this. I clicked “Sign in with Twitter” on my user profile page, nothing on the page changed and there was no notification that I connected anything. I then logged out and tried to log in with Twitter again, and got the same error.

    Thanks for the help!

    Plugin Author Louy Alakkad


    Well, when you click the “Sign in with Twitter” button in your profile page it should disappear and you should see your username there…

    P.S. it’s in your /wp-admin/profile.php page not the TweetPress options page.

    Yes, I understand that. It’s not working though. I’m on when I try this. Clicking “Sign in with Twitter” does nothing.

    I’ve also tried it from the TweetPress app and it does nothing there either:

    I thought I figured out the problem: I had already allowed access using a different plugin, so I went to Twitter and revoked access. I tried signing in again at my profile page and it gave me the authorization screen, so I thought it was going to work… but it brought me back to profile page and it still has the “Sign in with Twitter” button there.

    Any other ideas?

    Plugin Author Louy Alakkad


    Ummm… That’s wired!
    I’ve tried to re-create the situation but I’m unable to.
    Can you give me any info I can use?

    What information do you need? I just tried resetting my keys on Twitter and entering the new info into the app settings. Still nothing.

    Let me know what info you need.

    Any other help? It’s still not working.

    Plugin Author Louy Alakkad


    Well, I’ve just tried that and it’s working on my blog!
    What version of TP, WP are you using?

    I am using version 3.0.4 of WP, and version 1.3 of TP.

    I deleted and reinstalled it, and now it’s working.

    Plugin Author Louy Alakkad


    oh! great 😉

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Plugin: TP – TweetPress] Twitter not authorizing’ is closed to new replies.