Top 10 - Popular posts plugin for WordPress
[Plugin: Top 10] Doesn't show any posts (13 posts)

  1. ChrisBuck
    Posted 3 years ago #

    Not sure what the problem is, but the widget won't show any posts, regardless of the value put into the form, 1 day, 10 days, whatever. Hoping its not incompatible with other plugins.


  2. Ajay
    Plugin Author

    Posted 3 years ago #

    Is this a problem with both daily and top posts widgets?

  3. I too am having this problem. The weird thing is it works perfectly on my main domain, but doesn't display any posts when I have it installed an activated on one of my sub-domains.

    Is this currently a known issue regarding sub-domain usage?


    EDIT: It doesn't show any posts. Not in the Daily Popular, or in the Popular Posts widgets. It also does not populate any posts when viewing from the plugin settings page.

  4. Ajay
    Plugin Author

    Posted 3 years ago #

    Josh, can you post a URL to your blog so I can check it out.

    There shouldn't be an issue with sub-domains.

  5. Of course.

    Main site:
    http://www.joshlobe.com (plugin working fine)
    http://www.plugins.joshlobe.com (plugin not showing posts)

    Thank you.

  6. Ajay
    Plugin Author

    Posted 3 years ago #


    In the sub-domain link, I can see the hits being tracked properly in the visitor count at the bottom of your post.

    Where are you expecting the list? Sidebar? It doesn't seem to show that the widget has been added in the sidebar.

  7. I'm sorry. It was only visible from my admin panel. Helps me keep track of which pages are getting the most views :)

    I have added the plugin to a widget area in the subdomain:

    It is on the right, at the very bottom.

    You can see it's not populating with any results.


    EDIT: Is that page count at the bottom of each post/page something added by your plugin? I thought it was something added by the theme I was using on that site.. lol.

  8. Ajay
    Plugin Author

    Posted 3 years ago #

    The page count is added by the plugin :)

    But, I can't figure out why the posts aren't being displayed. The plugin is counting perfectly.

    Could it be possible for you to temporarily switch to another theme / Twenty Ten to see if it displays.

    Also, can you try to see if the Popular option works, not daily-popular

  9. Good to know :)

    I switched to the twentyten theme, and received the same results.

    I've also added the "Popular" widget below the "Daily Popular", also with the same results. (I'll leave it in the sidebar for now)

    I'll go through and do the plugin thing next. Perhaps there is a conflict with another plugin I use?

  10. Ajay
    Plugin Author

    Posted 3 years ago #

    That could be an issue. Is the sub-domain a completely different blog?

  11. Yes. It is a separate installation of wordpress and also using a different theme from my main blog.

    I'll go through the plugin/theme deactivating and switching and post back.

  12. My apologies. I'm an idiot.

    My subdomain is setup where post excerpts are shown on the main page... but each post excerpt links to a page. Then, on this page I give the information for each plugin.

    So, because the option to exclude pages in the posts results is enabled by default, neither of the two boxes were populating (because no-one ever visited actual posts... they all link to pages).

    I disabled the option "Exclude Pages in display of Popular Posts?", and now all is good. I can see the number of views each of my PAGES (lol) is getting, by viewing it from the dashboard. EXACTLY what I was trying to accomplish.

    Thank you very much for the prompt support. It now works exactly how I need, and I will be donating.

    Sorry to have wasted your time ;)

  13. Ajay
    Plugin Author

    Posted 3 years ago #

    No problem. Glad you got it sorted out! It sure was confusing for me. Now, am glad to know the plugin actually works :)

    Just to keep you in the loop. I will be releasing a new option that will allow you to choose from various post types. I added this feature in my plugin (link below) and am porting the same into Top 10.

    This will disable your option above and you'll need to use the new settings.


Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic