Support » Plugins » [Plugin: TinyMCEComments] Not working with nested comments in 2.7

Viewing 15 replies - 1 through 15 (of 21 total)
  • Yeah, I noticed that too. Deactivating it until that gets fixed.

    Please fix soon!

    use comment form quicktags, its way bitter and safer.

    The problem with nested comment is originated that the “comment form popped below the comment you want to reply” effect.

    The WordPress built in function (maybe from theme I suppose) “copies” the original one and place it below a specific comment, and hides the original one. However, it does not move TinyMCE keybinds, i.e. “Click this specific place will bold the text I highlight”, “type any keys into the custom built JavaScript Object”, blah blah blah… And so it seems “locked”, does not react to user keystrokes and mouse clicks.

    I don’t know if that could be solve by the modifying the plugin or the theme or WP itself, and currently I don’t have the time to look into…

    Thanks mk for an explanation. Sorry this can’t be resolved yet, as nested comments is a priority for many users.



    I managed to get tinymce working with threaded comments by hacking the comment-reply.js and basically destroying the editor before “a move” and reinitialising it afterwards… If you’re interested here’s my modified version.

    This obviously isn’t really a proper solution as it changes a wordpress core file but I haven’t found a way of hooking into that file without changing it. Maybe it would be good if the addComment object would allow to set two event handlers which are called before and after the form move…


    bforchhammer, I used the modified version you wrote but I’am having a new problem: I have a doble TinyMCE box now, one taht works and the other that doesn’t. Here you have a pict.

    Any suggestions?

    Thank you very much!



    @arroba3: When someone clicks on a reply button my changes to that file should cause any tinymce instanced which are attached to the comments textarea to be removed and then re-created after the form has been moved… It seems that the old editor instance does not get removed.

    The only thing which I think that you need for my changes to work is that the textarea has the id “comment” (and the textarea alone.. ids are supposed to be unique).

    Sorry I can’t be of more help, but I’m actually not using the TinyMCEComments plugin at the moment because the mce editor is hardcoded into our theme… so I don’t know if there’s anything else that could interfere with it.

    Thanks bforchhammer! That worked for me.



    @mk_is_here: Sorry, I haven’t found an email address or anything to contact you on, so I’m just posting this here.

    I’ve worked out a “proper” solution which does not require changing core files any more and also uses more of wordpress’ core tinymce functions (which makes it more robust to upgrades); If you’re interested please send me an email and I’ll help to get it integrated into your plugin.

    Hi all, and many thanks to @bforchhammer, we now have threaded comment support in 0.4.7! Feedbacks are welcome.

    mk, it doesn’t work for me on either of my two sites with different themes.
    Previously when I clicked reply it didn’t allow me to type anything at all. Now I can make a comment but it doesn’t show as a nested comment.

    Any ideas?

    steupz, I have tried on the default theme only. WOuld you mind telling me the themes you are using?

    mk, thanks for replying.
    I am using a very well designed child theme, Shadow, on the Options theme by Justin Tadlock.
    That’s on my primary site,

    And I am using the default Kubrick on my other site

    Both have the same issue, I can utilise all the features for a regular comment, but if I reply to a comment, it doesn’t show as nested and it shows as a ‘single comment’ at the bottom of all comments.

    Can you point me to a site where it works perfectly so I can have a look?

    Update: got it to work on using Kubrick theme, once.
    Literally,one time.

    I made a reply, it nested, another user replied, didn’t work; then I tried again and it didn’t work thereafter.
    [tearing my hair out]

    Yeah, I could simulate that on my testbed WordPress…
    Searching for way to fix the problem. Somebody may have an idea?

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘[Plugin: TinyMCEComments] Not working with nested comments in 2.7’ is closed to new replies.