WordPress.org

Support

Support » How-To and Troubleshooting » [Plugin: TinyMCE Advanced] TinyMCE has some warning message for WordPress 2.7.

[Plugin: TinyMCE Advanced] TinyMCE has some warning message for WordPress 2.7.

  • Hi all,
    I have some warning message like

    Warning: is_file() [function.is-file]: open_basedir restriction in effect. File(/en.js) is not within the allowed path(s): (/home/www/virtual/XXXX.com/:/usr/share/php:/tmp) in /home/www/virtual/XXXX.com/htdocs/wp-admin/includes/post.php on line 1187
    
    Warning: is_file() [function.is-file]: open_basedir restriction in effect. File(/en_dlg.js) is not within the allowed path(s): (/home/www/virtual/XXXX.com/:/usr/share/php:/tmp) in /home/www/virtual/XXXX.com/htdocs/wp-admin/includes/post.php on line 1190
    
    Warning: is_file() [function.is-file]: open_basedir restriction in effect. File(/en.js) is not within the allowed path(s): (/home/www/virtual/XXXX.com/:/usr/share/php:/tmp) in /home/www/virtual/XXXX.com/htdocs/wp-admin/includes/post.php on line 1187
    
    Warning: is_file() [function.is-file]: open_basedir restriction in effect. File(/en_dlg.js) is not within the allowed path(s): (/home/www/virtual/XXXX.com/:/usr/share/php:/tmp) in /home/www/virtual/XXXX.com/htdocs/wp-admin/includes/post.php on line 1190

    I haven’t found these messages when I disable TiMCE plugin.
    Anyway, I found someone has this problem like me too.
    http://wordpress.org/support/topic/224372

    Please help me to fix this problem.
    Thank you so much.

Viewing 5 replies - 1 through 5 (of 5 total)
  • jaggerkieth
    Member

    @jaggerkieth

    i’m also using that plugin but all thing are ok. and never have this problem.

    Anyway, I have just changed WYSIWYG to http://www.deanlee.cn/wordpress/fckeditor-for-wordpress-plugin/

    I think, my problem happened from the AutoUpdate plugin which I used it when I updated WordPress from version 2.4 to 2.7.

    Andrew Ozz
    WordPress Dev

    @azaozz

    @aoddy this is how the TinyMCE configuration looks for translations for external plugins. The warnings mean that your host has enabled a restriction on which files can be opened by php. That seems to allow all files in your webroot directory as it should, perhaps you moved the plugins directory above it? In that case you can ask your host to include wp-content/plugins in the allowed paths.

    @azaozz, thanks for your suggestion. I will try to talk this issue to my host.

    NewKidOnTheBlock
    Member

    @newkidontheblock

    Same problem here, isn’t there any workaround? And why the heck this happend only after updating to 2.7 and not before?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: TinyMCE Advanced] TinyMCE has some warning message for WordPress 2.7.’ is closed to new replies.