Support » Plugins » [Plugin: TinyMCE Advanced] Tiny MCE settings not saving

Viewing 13 replies - 1 through 13 (of 13 total)
  • Andrew Ozz


    WordPress Dev

    Stupid question but… Did you click on Save Changes after clicking the checkbox? If yes, can you look in the html source on the New Post screen for a script tag with source like wp-content/plugins/tinymce-advanced/js/tadv_replace.js.

    I’ve had the same problem. Unsure of it’s a WP 3.0 issue, but what happens on my end is the same. While in the Tiny MCE Advanced area of Admin, clicking save changes does nothing – no browser refresh, no changes accepted, no change in cursor to the ‘hourglass’, basically no browser indication that it received a click input.

    As well, (and by the way, I LOVE this plugin – much easier to work with than CKEditor for adding styles and general usage), some other areas of WP won’t work with this plugin enabled. It’s been mentioned in other posts too – things like the left sidebars (menus) in WP’s Admin. Normally you can click the little arrow to reveal the subpages in Posts, Pages, Links, etc. TinyMCE Advanced disable this for whatever reason. It also disables the ability to “show” images when I try to add an image to a Post (I search Media Library, it finds the images, but clicking the “show” button won’t slide it down so that I can view options). So it seems something about this plugin disables default slide functionality in the rest of WordPress.

    When I go into the Pages area to modify a page, the left sidebars open up as though I left a few open. And clicking the little side arrows shows the functionality is back, for them to slide at least. But the ajax image problem (can’t “show”) is still there.

    Would love to see this worked out – it’s the best text editor I’ve found.

    For some added info, Firebug shows a javascript error on each page where functionality is gone: The TinyMCE Advanced page in WP, as well as the main areas for WP Admin. Clicking on Pages and showing all records, the error still exists. Clicking into an actual Page for edits, the sliding functionality returns to the sidebars in WP, and the error is gone. Clicking to add an image to the content area (and hence activating the ajax window for image upload), and Firebug shows the error returns.

    Here is the error:
    c is null
    Line 22

    Andrew Ozz


    WordPress Dev

    @focus97 it seems that tadv_replace.js is loaded on all pages in the admin. This is of course wrong. TinyMCE Advanced queues that file only when the editor.js is also queued (editor.js is a WP core file that is loaded with the Visual editor).

    Do you have any other plugins that deal with the editor? If not, could you have a look in your theme’s functions.php. There’s probably something like that: wp_enqueue_script('editor'); and it’s running on all pages in the admin.

    Not quite sure if these other plugins deal with the editor, but I would guess at least one does.

    Here are the active plugins I have installed:
    Cimy User Extra Fields
    Simple Press
    Terms of Use
    Theme My Login
    TinyMCE Advanced

    One thing to note, I commented out the troublesome code in tadv_replace.js, and the problems I encountered (including the Javascript error Firebug noted) are gone. This line:
    if ( c.value == '<br />\n' ) c.value = '';
    appears to be above an “if” statement that, itself, is already commented out. I simply extended the comment up a tad (sort of a pun) and I’m now able to click slide menus in WP Admin, reconfigure menus in TinyMCE, save changes to TinyMCE, etc.

    As for the functions.php – nothing in there calling the editor. I keep that file clean – just registration of sidebars, menus (wp 3.0), comments filter, and hiding profile fields (aim, jabber, etc.)

    Any thoughts based on the above plugins? Or is the line I commented not integral? (So far, that line doesn’t seem to have affected anything.)

    I’m having the same issue, or something similar with WP 3.0. It’s a new site so no other plugins except akismet. The buttons won’t drag and drop, and the save doesnt do anything.


    I did what you suggested and commented out the line in the tadv_replace.js line, but I’m still having the same problem.

    I cannot save the settings in the TinyMCE advanced settings panel and i cannot drag and drop the menu-items.

    What’s happening here? :-).

    Not sure what’s happening, but I’m surprised the commented line didn’t help. Maybe the comment isn’t in the right place? You can always copy the above link and save to override your file (it goes into the plugins folder for TinyMCE Advanced).

    The fix may be simpler than we think.
    IF someone could figure out the correct toggle.
    I could not get the save button to work.
    I couldnt move any items around.
    Then I UNCHECKED the box (under user profile) for do not use visual editor.
    The TinyMCE Adv plugin says make sure its checked.
    But here’s what weird.
    Move items on the tool bar
    I cannot save changes
    I Cannot uncheck any checkboxes for the plugin’s setting.
    I CANNOT insert an image from that grey icon above the tool bar (you know {insert image] [insert media] …. (those 4 buttons).

    So does anyone have a guess as to how to fix the toggle???


    IF YOU CHECK TO DISABLE – then you have all functionality.


    I ran into the same problem – can’t drag / drop plugins for TinyMCE and can’t save – with TinyMCE Advanced 3.2.7 and WP 3.01. I believe the problem is that now in WP 3.0 you can create your own editor-style.css to style the visual editor – so WP must keep the editor loaded maybe?, similar to what @andrew Ozz mentioned.

    I found commenting out line 22 in tdav_replace.js worked just fine, and fixes the problem. Remember to clear your browser cache after doing this if no change is noticed.

    If this doesn’t work, you can try disabling the visual editor in your User Profile, you can then modify the TinyMCE Advanced settings as you like – save your changes. Then go back and enable the visual editor – the changes should stick.

    Hope this helps

    had (have) same problem.
    firebug gave me “$(“#toolbar_1″).sortable is not a function” so no JS worked.

    Found that changing to standard theme helped to be able to change and save settings.
    Seems everything works fine now when changed back to my theme.

    If i add options to the toolbar i get only one line. The second line is not displayed.

    What am i doing wrong?

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Plugin: TinyMCE Advanced] Tiny MCE settings not saving’ is closed to new replies.