Support » Plugins and Hacks » [Plugin: TinyMCE Advanced] editor-style.css not being accessed

[Plugin: TinyMCE Advanced] editor-style.css not being accessed

Viewing 15 replies - 16 through 30 (of 32 total)
  • @mozakdesign

    Try clearing your browser cache and making sure TMCE Adv and WP are up to date. Otherwise I’m sure there’s more than one way for this problem to occur (not WLCMS).

    I have same problem, the editor works fine before, I did not add plugin but I upgrade the site in wp 3.3.1 and the tiny MCE to v(3.4.5). I done all the suggestion above except downgrading, but still not work.

    Same problem with my sites – no access to styles having cleared browser cache and disabled other plugins. Happened after upgrade to WP 3.3.1

    I have the same issue and a rather upset website user … any solutions welcomed …

    I deleted the latest upgrade and reinstalled 3.2.7. It works perfectly with WP 3.31

    I also am having this issue… would be great if the latest TinyMCE Advanced plugin worked with the latest WP. I set up custom styles for most of my clients, so this is a problem.

    We’re testing upgrading our sites to WP 3.3.1 and just happened to notice this little bug. We don’t use styles for much, but there are a couple that are necessary.

    We thought about going back to 3.2.7, but I think there were other features and bug-fixes added after that version that we would like to keep.

    So we ended up trying a hack that someone mentioned in the Feb. 2 comment on the TinyMCE Advanced plugin homepage.

    Basically, it looks like just using a bit of the old code from 3.2.7 to force the tadv-mce.css file to be loaded. Since I don’t believe that file is included in 3.4.5, we added it with just an ‘@import’ to point to our editor-style.css file in our Theme. If I knew PHP I would probably have been able to have the code point directly to the editor-style.css file and bypass the ‘tadv-mce.css’ file altogether, as I don’t think that’s been used for a few versions (correct?!?).

    Hopefully this will suffice until a proper fix can be published. I’m pretty sure we don’t lose any of the features from 3.4.5, just get the style sheet loading again. I’m sure someone who knows PHP well could figure out a better and more permanent solution much quicker. I’d love to hear about it!

    Just a bit more after some testing.

    It appears that we started getting the issue of styles working until we updated the page/post, then they disappeared (even after our hack mentioned above) when in Safari (FF fine). So it looks like we got the bug described here.

    Just not sure if we got this bug after doing our ‘hack’ fix, after updating WP to 3.3.1, after updating TinyMCE Advanced to 3.4.5, or if we just had never noticed it before.

    At any rate, we installed the TinyMCE Advanced Configuration plugin mentioned in the other thread (not happy about yet another plugin), and it did actually work – styles no longer disappear in Safari. So we now get a drop-down list of JUST the styles we want our client to see (none of the default WP ones). And we even make an entry to limit the formatting choices to only those we use as well. So this is actually better than it was before.

    Just hoping the TinyMCE Advanced Configuration plugin doesn’t cause other issues, and that when this whole things gets completely fixed properly, we don’t have issues when updating now.

    Just noticed this again in another fresh install. I feel like it has worked in previous versions that were upgraded to the latest and greatest. Is there any update on this?

    I just carried on using Tiny 3.2.7. It works perfectly with latest wordpress.

    I am having the same issue. Running WordPress 3.3.2, TinyMCE Advanced and using the BlankSlate theme.

    Any solutions on fixing this?

    Hi Smitty,
    Go to the plug in web site and download 3.2.7 it works and it’s simple to achieve the desired result

    I downgraded it shows up in the dropdown, but if I go to a different page it disappears.

    I just checked a lot of my pages and it shows up in all the ones I looked at.This may be of no use whatsoever, but it may be worth a try (??) Empty your cache and loo at the pages again. Other than that I don’t kno what to suggest. Once I found the latest Tiny MCE was not working I downloaded the older version and used that. In tiny settings, I have both boxes ticked in settings (Tiny MCE) and I also ignored the instructions for Tiny MCE and copied and pasted the full style description rather than just the name of the style into the theme style sheet e.g
    .songtitle {
    color: #e7dd9c;
    font-weight: bold;

    rather than just

    Hope this helps

    seems to be working fine in Firefox. Right now it is importing all the styles from my style.css file. How do I get it just to do the editor-style.css file?

Viewing 15 replies - 16 through 30 (of 32 total)
  • The topic ‘[Plugin: TinyMCE Advanced] editor-style.css not being accessed’ is closed to new replies.