WordPress.org

Support

Support » Plugins and Hacks » [Plugin: TinyMCE Advanced] Does TinyMce Advanced Styles allow for pseudo selectors?

[Plugin: TinyMCE Advanced] Does TinyMce Advanced Styles allow for pseudo selectors?

  • akamaxbuz
    Member

    @akamaxbuz

    I am trying to add a style for quote marks using this CSS below but it does not show up in the dd menu. I do have other Styles in the dd menu.

    .lft-bigqte:before {
    content: “\201C”;
    color: #AAAAAA;
    font-size: 30px;
    font-style: normal;
    font-weight: bold;
    line-height: 5px;
    position: relative;
    }
    .rt-bigqte-rt:after {
    content: “\201D”;
    color: #AAAAAA;
    font-size: 30px;
    font-style: normal;
    font-weight: bold;
    line-height: 5px;
    position: relative;
    top: 11px;
    }

    http://wordpress.org/extend/plugins/tinymce-advanced/

Viewing 1 replies (of 1 total)
  • Plugin Author Andrew Ozz
    WordPress Dev

    @azaozz

    It usually takes some effort to force the browser to refresh the CSS for the iframe after editing it. Browsers tend to keep the old styles cached for a long time.

    TinyMCE gets the class names from the same place, so best to delete browser cache, quit it and start it again to make sure the changes are noticed.

    Also not sure which browsers support :before and :after in contentEditable mode. May need other tweaks.

Viewing 1 replies (of 1 total)
  • The topic ‘[Plugin: TinyMCE Advanced] Does TinyMce Advanced Styles allow for pseudo selectors?’ is closed to new replies.