Timthumb Vulnerability Scanner
Version 1.51 bug - error warning when no timthumbs (4 posts)

  1. WayneM1
    Posted 3 years ago #

    My WordPress installations that have no timthumb scripts get this error at the top of the plugin scan page when I run the scan.

    Warning: Invalid argument supplied for foreach() in /home/...../wp-content/plugins/timthumb-vulnerability-scanner/class-cg-tvs-plugin.php on line 115

    I know... if there are no timthumbs to scan for why bother? Well, because you don't know if there are any until you do.

    I don't think the previous version behaved this way.

    Thanks again for a great plugin.


  2. redcocker
    Posted 3 years ago #

    I got same warning in ver 1.51 when I run the scan.

  3. game writer
    Posted 3 years ago #

    Same here. V 1.51. Looks sloppy.

  4. Peter Butler
    Plugin Author

    Posted 3 years ago #

    Should be fixed with 1.52. Sorry it took me so long to get to this, guys.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Timthumb Vulnerability Scanner
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic