Support » Plugins and Hacks » [Plugin: thumbGen] New settings annoying

[Plugin: thumbGen] New settings annoying

  • beetrootman


    The new settings are just annoying. Why keep changing things, both times I have upadted the plugin it has stopped working.

    The first version of the plugin was super simple and easy, you are overdoing it with new options.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author sebastianbarria


    Hi beetrootman.
    Well… thanks for using my plugin.
    I completely understand about what you’re saying, but I have an explanation for this: since I released my first version I allways had in mind to make the plugin work like it’s working right now (just ask for the image url, the with and height). The problem I had is that I needed to add more functionaily to the plugin (like the option to return or print the url of the result image). So if I wanted to add a new functionality it will finish being a very long list of parameters, wich make it more complex. So I decided to make this sustancial change now, before keeping updating (because then it will be too late), because from now I will be able to add more functionality without affecting the functionality anymore.
    I tried in this new version not to affect the sites that had the plugin already installed, and it worked for those who’s using the simple configuration, but but it will affect the ones using the lasts parameters (like $grayscale or $return parameters). In that case you’ll have to update the plugin, otherwise you shouldn’t.
    But anyway, please refer to the documentation and sorry if this changes have affected you. It won’t change anymore and I’ll make sure the plugin to work in later versions.



    Hi, Ok I understand about the parameters. Don’t get me wrong it is an excellent plugin and I am grateful for it.

    It was just frustrating that on the first update the default folder for images was changed, it could have been left as uploads/cache with the option to change. And next time round I had to go and and recode the template everywhere thumbgen was used.

    I am still having a problem that the two pieces of code below give the same image name. When I would presume they should be different since one is grayscale and the other is not.



    Plugin Author sebastianbarria


    Hi beetrootman.
    TRUE!… I was calling the wrong variable to generate the iamge name. Thanks!. I’ll fix it right now. So please, update the plugin and the new names will be generated correctly.
    About the folder I’ve decided to create the new folder (thumbgen_cache) because I’ve added the option to clean the cache folder, and since that folder is used by other plugins or wordpress itself, it would be wrong if the plugin delete files other than the ones generated by itself.

    Good luck!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: thumbGen] New settings annoying’ is closed to new replies.