Support » Plugin: Multisite Robots.txt Manager » Plugin thinks mapped sites are non-mapped

  • Resolved flyingpylon


    I have a multisite install using subdirectories and all sites are mapped to their own domain using the WordPress MU Domain Mapping plugin. The sites all seem to work fine.

    I installed Multisite Robots.txt Manager a few months ago (maybe more) and was able to specify that the sitemap url for each site should be added to the robots.txt file (I also added the actual url). Everything worked fine, and still works fine for the sites that were setup at that time.

    However, when I tried to add a new (mapped) site today, I am no longer able to specify that the sitemap url should be added because the plugin thinks that the site is non-mapped. Nor can I modify older sites because the plugin also thinks that they are non-mapped. But they are indeed all mapped!

    The plugin seems to assume that if a site’s “path” setting is something other than “/”, that it must be non-mapped. But at least in my case, that is not true. In the Network Site Settings, the domain is still set to the root domain and the path is still set to the site subdirectory, but everything works fine. Sitemaps are generated by Yoast’s WordPress SEO plugin, and they appear correctly at “”.

    Was this a change that was introduced in a recent update? Is there any way to override it? Or do I have something configured incorrectly?


Viewing 2 replies - 1 through 2 (of 2 total)
  • To resolve the problem, I went ahead and commented out lines 204 and 572 in ms-robotstxt-manager.php.

    //if ( $get_blog_path != "/" ) { $readonly = 'readonly="readonly"'; }

    I think your plugin is incorrectly assuming that:

    • Sites with a path that is anything other than “/” are not mapped
    • That there is no way for a site in a subdirectory to have its sitemap or robots.txt file appear in the root of the site (perhaps it could be called a virtual root)

    Other than that, it’s a great plugin. Thanks for creating it.

    Plugin Author tribalNerd


    Hello flyingpylon,
    The newest version, 0.4.0, should correct the issue you were having.

    Let me know if you have any other issues.


Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Plugin thinks mapped sites are non-mapped’ is closed to new replies.