Theme My Login
[closed] Something strange with Auto-Login script (7 posts)

  1. dassoubarna
    Posted 3 years ago #

    I have placed the auto login script as per Jeff's example. But the "New User Notification" emails aren't being delivered to either admin or users. I have tried several hours to fix it, but it doesn't work. When I omit the exit; from the code it did login the new user as well as send the notification e-mail, but the redirection was not happened at all. Could any one have any suggestion to solve that ? Thanks in advance.

    function auto_login_after_user_registration( $user_id ) {
        wp_set_auth_cookie( $user_id, false, is_ssl() );
        wp_redirect( get_option('siteurl') . '/after-registration/' );
    add_action( 'tml_new_user_registered', 'auto_login_after_user_registration', 11 );


  2. Tony
    Posted 2 years ago #

    Did you figure this out? If so then can you please tell me? I'm also having trouble with this...

  3. dassoubarna
    Posted 2 years ago #

    I don't figure it out. I go for a different approach to resolve that problem without using "Theme My Login" plugin.

  4. Jeff Farthing
    Plugin Author

    Posted 2 years ago #

    Are you using any of TML's modules?

  5. learningmind
    Posted 2 years ago #

    I have the opposite problem: I would like to disable new user registration notifications and I can't, I have already tried many things but I continue recieving the notification emails. The problem is that too many spammers register on my website every day and I get about 30-40 emails a day!!!
    Does everyone know how to stop it?

  6. Jeff Farthing
    Plugin Author

    Posted 2 years ago #

    Moderators, please? See here and here.

  7. esmi
    Forum Moderator
    Posted 2 years ago #

    @learningmind: Please post your own topic and stop tagging onto old topics.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Theme My Login
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.