Theme My Login
[resolved] SEO issues (6 posts)

  1. solidnuts
    Posted 4 years ago #

    I noticed theme my plugin creates duplicated content which affects SEO it adds the following to each post.


    Any chance you might add nofollow or noindex?

  2. Jeff Farthing
    Plugin Author

    Posted 4 years ago #

    What do you mean "adds it to each post"?

  3. Johan van der Wijk
    Posted 4 years ago #

    The problem is that Google indexes duplicate urls because it can spider the pages with the action parameter.

    There are three ways to fix this:
    - using the canonical meta tag
    - telling the Google spider to ignore the action, redirect_to and instance parameters in Webmaster Tools (See: Site configuration - Settings - Parameter handling)
    - adding rel=nofollow to all the links that are generated by the Theme My Login in the plugin code

    Jeff, it would be brilliant if you could include the nofollow tag in the links that are generated by the widget. (the register and lost password links).

  4. Jeff Farthing
    Plugin Author

    Posted 4 years ago #

    I see. Will do in next release.

  5. HF T
    Posted 4 years ago #


    I've got this exact same problem and I'm glad that I'm not the only one. I've got 180 pages indexed with Google 3 times...

    Thanks for the ideas Johan, I've used the Webmaster Tools parameter ignore function to see if that solves it... It had only picked up 'action' and 'instance', so I've set them to ignor. Will this alone drop the pages from their index and prevent crawling?

    In the meantime, that seems like a bit of a 'botch job'... Where in the theme-my-login-widget.php file can I edit links to nofollow?

    Also is there not a way that we can put 'noindex' on these pages? That seems to be the only proper way to deal with this...

    Many Thanks.

  6. Jeff Farthing
    Plugin Author

    Posted 4 years ago #

    In the meantime, you can create your own templates for the plugin and add the parameters to the links yourselves.

    Just simply copy the templates from theme-my-login/templates into your current theme's directory. The change $template->the_action_links() to the following:

    <?php if ( $action_links = $template->get_action_links( $args ) ) {
    	echo '<ul class="tml-action-links">' . "\n";
    	foreach ( (array) $action_links as $link ) {
    		echo '<li><a href="' . esc_url( $link['url'] ) . '" rel="nofollow">' . esc_html( $link['title'] ) . '</a></li>' . "\n";
    	echo '</ul>' . "\n";
    } ?>

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Theme My Login
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic