Support » Plugins and Hacks » Theme My Login » [Plugin: Theme My Login] Latest Upgrade Error

[Plugin: Theme My Login] Latest Upgrade Error

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Jeff Farthing


    Sounds like it has to do with the deprecation of wp-includes/registration.php in WordPress 3.1. However, the code in the plugin tells it to load it still if the version is below 3.1. I see you’re using 3.0.5, so it should still load it.

    if ( version_compare( $GLOBALS['wp_version'], '3.1', '<' ) )
    	require_once( ABSPATH . WPINC . '/registration.php' );
    Plugin Author Jeff Farthing


    Try this, create a file called theme-my-login-custom.php in your /plugins directory. Then add the following to it:

    <?php function tml_request( &$theme_my_login ) {
    	if ( 'register' == $theme_my_login->request_action )
    		require_once( ABSPATH . WPINC . '/registration.php' );
    add_action( 'tml_request', 'tml_request' ); ?>

    Let me know if that resolves it.

    Ok I threw it in, straight to the plugins folder and it still just says theme-my-login when you hit login.

    So then I tried putting it in the actual theme-my-login folder, but that was a no go as well.

    And btw, thanks for getting back to me so quickly.

    Ok you know what… So when I re-activated the plugin, it was throwing all kinds of errors. So I de-activated, removed the new .php, reactivated, and all is well now. Go figure.

    Thanks so much for your help!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: Theme My Login] Latest Upgrade Error’ is closed to new replies.