Support » Plugin: Theme My Login » [Plugin: Theme My Login] Disabling fields on profile page

  • Resolved Daedalon


    How to disable fields on the profile page? Currently there are settings that are already effectively disabled through other plugins, but the options are still shown.

    The best option would be to disable/enable them in the plugin/module settings. I’d be glad to test a development snapshot with this feature.

    In the meanwhile, I’m applying a CSS solution as a workaround that has the downsides of showing the elements in HTML and being a drag to update.

Viewing 4 replies - 1 through 4 (of 4 total)
  • For those looking for the workaround, I got done what I wanted by adding these in my theme’s style.css:

    /* Profile page customizations */
    form#your-profile h3:first-of-type , form#your-profile table:first-of-type{
    display: none;
    div#pass-strength-result {
    visibility: hidden;
    height: 0;
    margin: 0;
    border: 0;
    padding: 0;

    The first CSS rule is for hiding the first table, Personal settings, completely. This table included the options for disabling the graphical editor, changin the admin panel color scheme, using keyboard shortcuts to administer comments and showing the admin bar.

    The second one is a workaround to hide the currently malfunctioning password strength meter.

    Added this to the CSS due to IE8 and earlier not supporting the “:first-of-type” CSS selector.

    /* IE8 doesn’t support the above so let’s hide manually what we can */ {
    display: none;

    After this the admin panel color setting is still displayed and I’m not aware of a suitable CSS workaround that would disable it in IE8 and earlier.

    Plugin Author Jeff Farthing


    The best method is to copy wp-content/plugins/theme-my-login/templates/profile-form.php to your current theme’s directory and remove the HTML of the fields you no longer wish to display.

    Perfect, thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: Theme My Login] Disabling fields on profile page’ is closed to new replies.