Support » Plugins and Hacks » [Resolved] [Plugin: Theme-Check] Warning: file_get_contents

[Resolved] [Plugin: Theme-Check] Warning: file_get_contents

Viewing 7 replies - 1 through 7 (of 7 total)
  • The main.php file hasn’t changed in 4 months. I think your problem comes from elsewhere.

    Alright Thanks Otto, Just switched to a new computer last week, might of had a bad file transfer.


    Just wondering..
    You included a version check of timthumb
    But it won’t validate the theme because of timthumb’s fopen etc.

    Why dind’t you integrate the ‘overlooking’ of these ‘errors’??


    I’m also getting the error message that bradthomas127 said too.

    I’m wondering if he was ever able to figure out what’s happening there. It’s pointing to my theme’s options panel but the first time I used this plugin a month ago, it didn’t show that warning. I have not changed anything inside the admin folder (although I have updated the theme check plugin) and now it’s giving an error.

    jami0821 it did end up going away not too sure what changes i made though, i think it might have been wp_enqueue_script(‘dashboard’); in my admin panel, it was causing plugins not to delete.

    I have the same error & found the solution at

    Basically – change line 29 to this: if(!is_dir($filename)) $other[$filename] = file_get_contents( $filename );

    Thanks turtlewin, that worked for me. Is it a windows7 and XAMPP thing?

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] [Plugin: Theme-Check] Warning: file_get_contents’ is closed to new replies.