Support » Plugin: Theme Check » [Plugin: Theme-Check] $GLOBALS['content_width'] not recognized

  • $GLOBALS['content_width'] = 750; in a theme produces the false error:

    > REQUIRED: No content width has been defined.

    Fix: run a preg_match() on

    '~\$GLOBALS\[\s*([\'"])content_width\\1\s*\]~'

    I write global variables always in the long form to make them stand out and because they are treated slightly different than global $var; $var = 'something';.

    http://wordpress.org/extend/plugins/theme-check/

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘[Plugin: Theme-Check] $GLOBALS['content_width'] not recognized’ is closed to new replies.