Support » Plugin: The Piecemaker 2 » [Plugin: The Piecemaker 2] Display in Header and not in POST / PAGE

Viewing 15 replies - 16 through 30 (of 31 total)
  • If I want to display it I would just simply insert the mentioned code in functions.php and in header.php -> <?php display_piecemaker(array(‘id’ => 1)); ?> ??? Well it doesn’t work…what am I dong wrong? (Piecemaker2) Thx

    I am having same problem as peterson.julia. Did you find any fix?

    I created an asset, and created a piecemaker. I inserted the code in functions.php and the following code in the proper place of my index.php:

    <?php if( is_home() ) {
    display_piecemaker(array('id' => 1));
    }
    ?>

    All that shows up is a big giant blank space. When I right click on it, I see that there is a Flash element there, but nothing shows up.

    I was experiencing the same problem. For some reason the Piecemaker only appears if the dimensions are 960×380…

    Anyone else experiencing this problem?

    It works for me, thank you!
    But I have another question: how can I centralize the piecemaker in my homepage?

    I have the same question as you fegw ….

    Hi everyone. I am having same problem as jeremyers1. Its just blank flash-player object. How to solve this problem?

    I have the same problem as jeremyers1 and kke. Can someone please help?

    Alright, I actually fixed that problem by adding transitions. But now, like 40cooper, I can’t get the second transition to start and more images to display.

    Alright, I got it working by fixing the transition speed. It was way too slow. But now I can’t get other transitions working besides the one that rubber-bands all the boxes out and then back in…

    Alright, I fixed this one by changing my transition offset and cube distance.

    I tried putting the following code in my theme’s functions.php file:

    /**
    	 * Function to use piece maker outside post content
    	 *
    	 **/
    
    	function display_piecemaker($att = null){
    		global $pm;
    
    		if(!is_array($att)){
    			$att = array(
    				'id' => $att,
    			);
    		}
    
    		echo $pm->replaceBooks($att);
    	}

    And then I put the following code in my header file where I want the piecemaker slideshow to appear:

    <?php {display_piecemaker(1);
    }
    ?>

    But I am getting the following error when I do so: Fatal error: Call to a member function attributes() on a non-object in /wp-content/plugins/piecemaker/piecemaker-main.php on line 1981

    What am I doing wrong and how can I fix this?

    Hello,

    I used the code above to get the piecemaker up and running on my site.

    But, when I put it in my header, the links above the piecemaker stop working. Not sure what is going on, but on my subpages the links up top work fine.

    Anyone have any ideas?

    good job man big THX halles !!

    I’m nota programmer but it was helpful I use piecemaker in sidebar the way u explained ! 🙂

    Hey, thanks for you help, I managed to get it running, but I have problem with centering the object. I’ve tried many codes, but none is working, the header is still on the left side.

    <?php if( is_home() ) {
    display_piecemaker(array('id' => 1));
    }
    ?>

    Can you help me how to center this code? I’m using Scarlett Theme. Put this code in slide.php, it works fine, but I need it in center, where and what to do now? Can you please help me I’m desperate.

    Thank you so much.

    There’s example how does it look like on my webpage, the shadow of slide is ok I guess it’s just wrong setup in slide settings in wordpress admin…
    CLICK

    use html code without declaring it. example

    <center>
    
    <?php
    display_piecemaker(10);
    
    ?>
    </center>

    it works perfectly example and in the theme file
    http://dejathegreat.zxq.net/Homepage/

Viewing 15 replies - 16 through 30 (of 31 total)
  • The topic ‘[Plugin: The Piecemaker 2] Display in Header and not in POST / PAGE’ is closed to new replies.