WordPress.org

Support

Support » Plugins and Hacks » The Google+ plugin » [Plugin: The Google plugin] not working, does not connect properly to G

[Plugin: The Google plugin] not working, does not connect properly to G

  • This G+ is not connecting properly to google … when I click on the button, a popup opens, tries to connect or something but it does not make it obviously and no +’s are seen either on my page or in the google account.

    There must be smth wrong with the script which connects to Google, as it gets stuck on that white popup and never moves on from there!

    Solution?

    Thanks

    http://wordpress.org/extend/plugins/google/

Viewing 14 replies - 1 through 14 (of 14 total)
  • Apparently a lot of people are having troubles. I get the popup, but then it promptly disappears, the settings page reloads, and I’m stuck with “Authenticate” button appearing.

    http://premium.wpmudev.org/forums/topic/not-importing

    Just too bad you have to pay for the support… Might have to find a different plugin.

    I spent hours troubleshooting an issue similar to this. Perhaps it’s the same problem you were having. I hope this helps…

    The token that Google was returning did not contain an attribute that The Google+ Plugin was expecting. I solved this by changing line 126 of lib/external/google/auth/apiOAuth2.php from…

    if (! isset($accessToken[‘access_token’]) || ! isset($accessToken[‘expires_in’]) || ! isset($accessToken[‘refresh_token’])) {

    … to …

    if (! isset($accessToken[‘access_token’]) || ! isset($accessToken[‘expires_in’]) ) {

    Once I did that, everything started working as intended. I’m not sure if this is a good long term fix or if it will cause other problems, but it’s working for me for now.

    Yes! That worked perfectly! Once I made that change the Authenticate button changed to Test.

    Thanks for the fix! I didn’t even know where to begin on that.

    Thank you! This has fixed my issue with the plugin as well.

    Well, it’s not completely fixed. It worked once. It looks like maybe the token expires because hourly (when the plugin tries to connect to import posts) I see this error in my logs:

    [Sat Jun 16 18:30:08 2012] [error] [client 192.168.1.5] PHP Fatal error: Uncaught exception ‘apiAuthException’ with message ‘Error refreshing the OAuth2 token, message: ‘invalid_request” in /var/www/public/blog/wp-content/plugins/google/lib/external/google/auth/apiOAuth2.php:184\nStack trace:\n#0 /var/www/public/blog/wp-content/plugins/google/lib/external/google/io/apiCurlIO.php(51): apiOAuth2->sign(Object(apiHttpRequest))\n#1 /var/www/public/blog/wp-content/plugins/google/lib/external/google/io/apiREST.php(90): apiCurlIO->authenticatedRequest(Object(apiHttpRequest))\n#2 /var/www/public/blog/wp-content/plugins/google/lib/external/google/service/apiServiceResource.php(144): apiREST::execute(Object(apiServiceRequest))\n#3 /var/www/public/blog/wp-content/plugins/google/lib/class_wdgpo_google_auth.php(98): apiServiceResource->__call(‘list’, Array)\n#4 /var/www/public/blog/wp-content/plugins/google/lib/class_wdgpo_google_auth.php(98): ActivitiesServiceResource->list(Array)\n#5 /var/www/public/blog/wp-content/plugins/google/lib/class_wdgpo_google_auth.php(86): Wdgpo_GoogleAuth->get_gplus_feed in /var/www/public/blog/wp-content/plugins/google/lib/external/google/auth/apiOAuth2.php on line 184

    If I deauthenticate and do it again, it works one more time. Does anyone have this working reliably?

    Anyone?

    I’m still having the issue where the token only seems to work once and then the plugin stops working with the error I posted above.

    No one, eh? Time to look for a new plugin that works I guess.

    Does a plugin exist that will post content from WP to Google+ ? I’m currently fiddling with WPGPlus, but it isn’t working for me. My interwebs skills are pretty beginner…

    My understandning is that the G+ API is read-only, so only G+ can post to G+.

    @windracer: I’ve noticed much the same thing, only no error displayed. Just doesn’t import.

    Thanks for the responses!

    @ahwm: glad to know I’m not the only one. For now I just de-authenticate and re-authenticate every few days to “freshen” up the widget. I hope there’s a fix from the developer eventually.

    No one, eh? Time to look for a new plugin that works I guess.

    Windracer, I’ve tested out a bunch but they’re all pretty weak. Which is why I was excited to finally find this one–the screenshot and settings panel suggests a high level of customization, and I want to be able to tweak its appearance.

    I tried modifying the php code as suggested above but it doesn’t work for me even once. Nothing imports, pop-up window disappears a half-second after attempting to authenticate. Tried it with multiple CLIENT IDs too, so I’m guessing the problem is on the coding side. Would love to see this resolved.

    I switched from this plugin to the Google+ Blog plugin (http://www.minimali.se/google+blog/). I’d recommend giving it a try. It doesn’t have as many features, but it works pretty reliably. I haven’t been impressed with the speed of new development, but it’s pretty solid as it is.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Plugin: The Google plugin] not working, does not connect properly to G’ is closed to new replies.
Skip to toolbar