Support » Plugins and Hacks » The Events Calendar » [Resolved] [Plugin: The Events Calendar] white screen of death in wp-admin

[Resolved] [Plugin: The Events Calendar] white screen of death in wp-admin

  • 1. Everything was working fine.

    2. I upgraded to the latest version of wordpress and the-events-calendar.

    3. Got the white screen of death in wp-admin (the front-end was all right though).

    4. Tracked it down to a language-related bug. If the site language is English, everything works fine, if it’s Romanian, I get the white screen of death in the wp-admin.


Viewing 15 replies - 1 through 15 (of 22 total)
  • Plugin Author Rob La Gatta


    Hey gab.ro. This is weird; since The Events Calendar doesn’t include a Russian translation that I can see, what are you using to change the plugin language itself? Did you create new po/mo files or is it a third-party plugin of some kind?

    Let me know and I’ll do what I can to point you in the right direction here. Thanks for your patience so far.

    Yeah, I created new po/mo files. And selected the language from the backend (since it’s a multi-site installation).

    Plugin Author Rob La Gatta


    Ah, it could be a multi-site issue with the translation but I’m not positive. If you want to send me over the .po/.mo files (to pro /a/ tri.be) I can give them a go and see if this happens on my install. Please include a link to this thread so I have a frame of reference. Thanks in advance!

    OK, I also tested it without any Romanian po/mo files and it behaves just the same:

    If the selected language is English, everything is aOK, but if the selected language is Romanian, the front-end is OK, but the back-end shows the white screen of death.

    You might wonder why I’m selecting the Romanian language if I have no Romanian po/mo files for your plugin. It’s because I need translating for WordPress, and the theme and other things. For the plugins where there are no Romanian po/mo files, the default (English) strings should be displayed. And I’m getting this behavior with all other plugins except for the-events-calendar.

    The site where this is happening is http://intranzitie.org/

    It’s public and “in production” (so to speak) so the inability to use your plugin is causing me hardship…

    Plugin Author Rob La Gatta


    Hey gab.ro. Thanks for the follow-up. I am happy to try and help resolve this issue as I can understand the pitfalls of having problematic code on a production environment. But I guess I’m still a bit confused as to what you’re doing here: how is the language being changed to Romanian? You say you’re switching back and forth between them…are you using WPML or qtranslate or something to do this?

    Hey! Thanks for your reply!

    I’m not using any plugins for multilingual support.

    I’m simply changing the language like you do in wp-config.php

    The only difference is that when a network of sites is used (WPMU), you get that option as a drop-down under Settings -> General.

    That’s all I’m doing…

    Plugin Author Rob La Gatta


    Ah, gotcha. Thanks for confirming as much. OK – I’m going to need a dev to take a look here as this is a bit outside my area of expertise by now, but stay tuned and we’ll hopefully help get this resolved for you shortly.

    Thank you, I sure hope this gets fixed. I can confirm that the problem is still present for plugin version 2.0.8, under WordPress 3.4.1.

    Plugin Author Rob La Gatta


    Hey Gab.ro. Just wanted to follow-up on this; we’ve been a bit behind as our support team tends to take their vacations in August, so everything has slowed down a bit these past few weeks. But I wanted to confirm that we’re having a hard time recreating this locally.

    Is it still a concern for you? If so, mind sending over a set of admin creds to pro a/ tri.be (with a link referencing this thread) so we can try and troubleshoot directly? We won’t make any changes to your site; mostly we just want to see the setup and take note of anything that could account for discrepancies. Thanks in advance!

    Hey roblagatta,

    I have done some huge progress today in fixing this.

    I deactivated all other plugins and activated the default theme.

    I messed up all the theme settings in the process, but at least I have found the culprit: it is WordPress Jetpack!

    The problem with The Events Calendar appears only when WordPress Jetpack is activated + connected to WordPress.com. If it is only activated but not connected to WordPress.com, there is no problem with The Events Calendar.

    I have no idea how to use pro a/ tri.be for sending admin creds. I would gladly also send FTP data, if you think it would help. But with this new information (jetpack) perhaps you will be able to recreate the problem locally.


    Plugin Author Rob La Gatta


    Thanks for the follow-up, gab.ro. Just a heads up that I’m going to be doing some local testing on this today and will follow-up with my results. No need to send over the creds for now but I may request them later this afternoon, depending on the results of my test. Cheers and thanks for your digging on this so far.

    Thanks mate! Can’t wait for the results!

    Plugin Author Rob La Gatta


    Hey again gab.ro. So I just tested this somewhat extensively on my test site, with both Jetpack linked to WordPress.com and not, and the behavior was exactly the same in both instances…and in both instances, The Events Calendar worked fine across the board without presenting any white screens of death.

    Will you send over those admin creds to pro (a) tri.be, via email? We will take a look directly at your site from there, if you don’t mind us logging in (we won’t change anything without asking you first). Let me know if that’s cool with you and thanks for your patience so far.


    Did you also try it with Jetpack and with any other language than English? Remember that’s the only case that I’m getting the problem.

    I don’t know the email address of pro (a) tri.be

    On the contact page if your website, I only found a contact form: http://tri.be/about/contact/

    Is it all right if I use that?


    Plugin Author Rob La Gatta


    Hey man. The email address of pro a/ tri.be is as I wrote it…pro (at) tri.be. I dont want to write the email address directly here for obvious reasons 🙂 Shoot it over and we’ll take a look from there.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Resolved] [Plugin: The Events Calendar] white screen of death in wp-admin’ is closed to new replies.
Skip to toolbar