WordPress.org

Support

Support » How-To and Troubleshooting » [Plugin: The Events Calendar] Unable to activate – Dashboard error msg

[Plugin: The Events Calendar] Unable to activate – Dashboard error msg

  • Hi all:

    Very excited to use this plugin. However, when I tried to activate it, there is apparently a fatal error message:

    Parse error: parse error, unexpected T_CONST, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or ‘}’ in /home/content/a/k/l/aklawonn/html/PM/wp/wp-content/plugins/the-events-calendar/the-events-calendar.php on line 13

    Could anyone help me out? Is there something I can insert? I am running this WP installation on a subdirectory of my blog (http://zoniereport.com/PM/wp), and I’m using PHP v5.0.

    http://wordpress.org/extend/plugins/the-events-calendar/

Viewing 15 replies - 1 through 15 (of 17 total)
  • Hello,

    I’m looking into this. In the meantime, can you absolutely make sure you’re running at least PHP 5?

    Thanks,

    Justin

    Thanks, Justin. Yes, I checked it out and I am running PHP 5.

    Hi,

    I’m at a loss, have asked some other contributors, and will post again if we find an answer. I hate to be a broken record, but here’s an alternative to using phpinfo() for getting your PHP version:

    <?php echo phpversion(); ?>

    Maybe php 4 is the default and you have to specify php 5 on a per directory basis (lame, but one of my hosts has this as a policy)

    Justin

    I’m having the same problem and getting the same error.

    I am using WP 2.9.1, php 5, the Suffusion theme and I have 3 plugins active:
    All in One SEO Pack
    Google Voice Widget Plugin
    WP Easy Uploader

    Adamklawonn, do you have any of these things in common?

    I’ve asked Kelsey and Peter to look into it. Maybe they can crack this nut.

    My guess is that you may be running PHP 5.0. We should update our README to require PHP > 5.1. Class constants are not supported by the language in PHP 5.0

    From PHP 5 Changelog

    Version 5.1.0

    24-Nov-2005
    Added support for class constants and static members for internal classes. (Dmitry, Michael Wallner)

    I’m getting the same error, server is running PHP 5.2.12.

    Parse error: syntax error, unexpected T_CONST, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or ‘}’ in /home/kevin/public_html/wp-content/plugins/the-events-calendar/the-events-calendar.php on line 14

    Hmm, nevermind. Apparently running php -v from the command line on the server and actually running a php script from the browser makes a difference. :-\ command line = 5.2.xx, php page = 4.4.x. Works now!

    Sweet – Adam can you mark this as resolved?

    In summary, this plugin now requires PHP 5.1. If you are running anything older, our plugin will simply not work.

    Sorry, don’t mean to confuse – not sure if the OP’s issue is resolved!

    Hi All,
    I just thought I’d add some detail on how I resolved this issue. The site I’m dealing with is hosted at godaddy.com. They have a “new” 2.0x version of their hosting system that supports 4.x / 5.x.

    When I first had this error I did the <?php echo phpversion(); ?> test and it returned the 4.x version. After searching the godaddy support site, I found that .php extensions are handled by ver 4.x and .php5 extensions are handled by ver 5.x. Changing the settings in the .htaccess for the site reverses this configuration. Now my php version shows as “PHP Version 5.2.5”

    This is what you add to your .htaccess file:
    AddHandler x-httpd-php5 .php
    AddHandler x-httpd-php .php4

    Plugin works and activates now.

    Thanks again!!

    Hi All,

    I am new in wordpress.
    I need help to show calendar with feature event with current date event with tomorrow, yesterday link in a page. I am installed the-events-calendar plugin but i am not been able to modified.

    Any budy can you please help me out with this problem.

    Thanks

    My new hero of the night is mdedmon. THANK YOU!

    I’m running WP 3.0-RC1 & verified my server is running PHP 5.2.9 (with option for change to 5.2.11, 5.3.1 & 6.. I’ve tried them all), but am still getting this error in the Plugins page after activation:

    Plugin could not be activated because it triggered a fatal error.
    Fatal error: Cannot redeclare the_events_calendar_version_check() (previously declared in /home/xxxx/public_html/wp-content/plugins/the-events-calendar/the-events-calendar.php:17) in /home/xxxx/public_html/wp-content/plugins/the-events-calendar/the-events-calendar.php on line 20

    Even though, it says it could not activate, it actually does & I see this error at the front end of the site:
    Catchable fatal error: Object of class WP_Error could not be converted to string in /home/xxxx/public_html/wp-content/plugins/the-events-calendar/the-events-calendar.class.php on line 773

    Any help would be GREATLY appreciated!

    I figured out my problem was that The Events Calendar didn’t like the permalink structure I had set up.

    So after going back to the default, I’m able to install The Events Calendar, BUT I’m stuck with the default WP permalink structure.

    Is it possible to use a custom permalink structure with The Events Calendar?

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Plugin: The Events Calendar] Unable to activate – Dashboard error msg’ is closed to new replies.
Skip to toolbar