WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: The Events Calendar] Some event links sending user to homepage

[Resolved] [Plugin: The Events Calendar] Some event links sending user to homepage

Viewing 15 replies - 1 through 15 (of 22 total)
  • Hey jabbamonkey,

    Strange behavior indeed. Have you tried deactivating all other plugins? What about refreshing permalinks by visiting Settings > Permalinks?

    – Jonah

    Yup. Tried both of those. Didn’t fix the issue…

    Are you using the latest version of the plugin (2.0.7)? Have you tried reverting to the Twenty Eleven theme? It could be a theme conflict…

    – Jonah

    It is version 2.0.7. I’ll try reverting to the theme late tonight (dont want to bring down the site in the middle of the day)

    I am having this issue as well. I have created my permalinks with no difference. This was working AFAIK before the update to 2.0.7.

    Hi guys, is there anything in particular about these few events that you can think of? Custom fields, recurring, specific category or any other pattern to the problem?

    im not sure whats wrong with this particular post, which exists before the small update, but if i simply add a -1 to the slug of the event, then save, and view the post, its fine.

    Hey MACscr,

    That is strange. Did you upgrade from pre 2.0 by chance? I wonder if something screwy happened with the migration for some events?

    – Jonah

    i did a couple weeks ago, but this post was created afterwards.

    @macscr – Is it only that post or are there more? Does adding a “-1” to the others fix it as well?

    @jabbamonkey – does adding a “-1” to your event slugs help with the issue? Did you just recently migrate from 2.0 too?

    Thanks,
    – Jonah

    I checked out two of the posts that it was occurring on. Adding -1 to those two slugs works for those two. Still have the others to figure out (and I’d hate to have to check each event I post every time)

    Upgrade from 2.0? To 2.0.7? Not sure exactly. The site is only about 3 months old, so I don’t think it’s that old. Think I only upgraded it once a few weeks ago (and I wasnt even aware of this occurring before).

    Hey guys,

    Well I’m wondering if this is strictly isolated to posts that were migrated vs. new events being created. Are you guys seeing this issue with new events at all?

    – Jonah

    Whats very odd is that now that post that i added “-1” to its slug no longer works and redirects to the home page again. What the heck is going on? No events were ever migrated on this system. It was even used until after 2.x. It was installed, but no events existed.

    Hey MACscr,

    Have you tried deactivating all other plugins?

    – Jonah

    Yep, no difference after deactivating other plugins.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Resolved] [Plugin: The Events Calendar] Some event links sending user to homepage’ is closed to new replies.