WordPress.org

Forums

The Events Calendar
Read more tag breaks link to event single page (4 posts)

  1. phantomdentist
    Member
    Posted 3 years ago #

    plugin version 2.0.5

    If I add a read more link to an event the links to the single event page go to the venue page instead.

    So if the link would normally go to

    http://www.mysite.com/our-event/event-name/

    it now goes to

    http://www.mysite.com/venue/venue-name/

    This occurs for the read more link and the h2 event title link. If I remove the read more tag and then save the post again the issue is resolved.

    Cheers

    http://wordpress.org/extend/plugins/the-events-calendar/

  2. Rob La Gatta
    Modern Tribe Support
    Plugin Author

    Posted 3 years ago #

    Hi there phantomdentist. Thanks for the note on this. I'm actually unable to recreate this in the current code-base on my default 2011 install, though I have had a couple users report it so far.

    Here are a few suggestions right off the bat:

    * It could be a permalinks-related issue. Resave your permalinks page to reset them.
    * Try to identify whether this is a conflict with another plugin. You can do so easily by deactivating any other plugins you've got active and checking whether the issue persists.
    * If it isn't a plugin conflict, it may be a theme one. If after deactivating all other plugins the issue persists, please revert to the default 2011 theme and test whether it's an issue there.

    If not, is there any chance you have a link to a site where I can check this out?

  3. gerobe
    Member
    Posted 3 years ago #

    I'm also having this issue. Regenerating the permalinks brings no success.

    I found out the following: If I edit an event and save it, the link is not working and goes to the venue and shows an upcoming event as already over.

    When I now click on the quickedit featue in the event list and save it from there, the link to the event is correct.

  4. Rob La Gatta
    Modern Tribe Support
    Plugin Author

    Posted 3 years ago #

    Hey Gerobe, thanks for the follow-up. Do you have permalinks enabled, or no? I was unable to recreate your first situation either. I created an event; added the "Read More" link; published it; then returned to the admin events list. I then clicked back into the entry, saved it again, and refreshed the frontend. There was no change and the Read More link still went to the same place. Have you tried the plugin deactivation route?

    Also, the issue with the events appearing as already over is a separate bug. You'll need to re-download and re-install the 2.0.5 code to get the hotfixed release that addresses that issue.

    Give it a go and let me know your results. I can try to troubleshoot from there.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • The Events Calendar
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic