WordPress.org

Forums

The Events Calendar
[resolved] Main website navigation disabled when displaying grid on a page (2 posts)

  1. thomats
    Member
    Posted 4 years ago #

    Hey there

    I have an issue with the event calendar (1.6.4) that i can't seem to solve.
    I'm having the grid displayed on a page template. I found a useful code snippet <?php query_posts('category_name=events'); ?> that I pasted into the page template to make it work. So far so good...

    Whenever I use the calendar navigation to jump from one month to another it messes up the main navigation of the website... all of the links in the navbar are no longer clickable. I've also noticed that it deletes the 'main' div which is wrapped around the event calendar code.

    Since I might sound confusing trying to explain this issue here's the code of the template file to show you what I'm talking about:

    <?php /* Template Name: Agenda */ ?>
    <?php get_header(); ?>          
    
                <div id="main">
    
                	<div id="tec-content" class="grid">
                	<?php query_posts('category_name=events'); ?>
    		<div id='tec-events-calendar-header' class="clearfix">
    			<h2 class="tec-cal-title"><?php _e('Calendar of Events', $spEvents->pluginDomain) ?></h2>
    			<span class='tec-month-nav'>
    				<span class='tec-prev-month'>
    					<a href='<?php echo events_get_previous_month_link(); ?>'>
    					← <?php echo events_get_previous_month_text(); ?>
    					</a>
    				</span>
    
    				<?php get_jump_to_date_calendar( "tec-" ); ?>
    
    				<span class='tec-next-month'>
    					<a href='<?php echo events_get_next_month_link(); ?>'>
    					<?php echo events_get_next_month_text(); ?> →
    					</a>
    				</span>
    			</span>
    
    			<span class='tec-calendar-buttons'>
    				<a class='tec-button-off' href='<?php echo events_get_listview_link(); ?>'><?php _e('Event List', $spEvents->pluginDomain)?></a>
    				<a class='tec-button-on' href='<?php echo events_get_gridview_link(); ?>'><?php _e('Calendar', $spEvents->pluginDomain)?></a>
    			</span>
    		</div><!-- tec-events-calendar-header -->
    		<?php
    		global $wp_query;
    		$tecCatObject = get_category( $wp_query->query_vars['cat'])
    		?>
    		<a class="ical" href="<?php bloginfo('home'); ?>/?ical=<?php echo $tecCatObject->slug; ?>"><?php _e('iCal Import', $spEvents->pluginDomain) ?></a>
    		<?php event_grid_view(); // See the plugins/the-events-calendar/views/table.php template for customization ?>
    	</div>
    <?php /* For custom template builders...
    	   * The following init method should be called before any other loop happens.
    	   */
    $wp_query->init(); ?>
    
                </div>
    <?php get_footer(); ?>

    The div called 'main' which is wrapping the calendar code just disappears whenever I use the calendar navigation on the website and the main menu of the site is no longer usable...
    You can check out the site here. If you navigate to another month you will see what I'm talking about. :)

    I'm really running out of ideas how to solve this problem... Any help would be greatly appreciated!

    Thank you guys,
    thomats

    http://wordpress.org/extend/plugins/the-events-calendar/

  2. gizmo81
    Member
    Posted 4 years ago #

    Hi Thomats,

    i see you calender now is working, I have the same issue, as soon as I put that query_posts snippet in the navigation no longer worked. Can you please advise what you did to get it to work?

    Cheers
    Gizmo

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic