Support » Plugin: The Events Calendar » [Plugin: The Events Calendar] Google Map Link Not Working

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Rob La Gatta


    Hey Carter – that’s an odd issue. I’m seeing it too; you click the Google Map link and it takes you right back to the page you’re already on. I haven’t seen this before but a few suggestions right off the bat:

    * Make sure you’re running the latest version of WordPress.
    * Make sure you’re running the latest version of the plugin (2.0.7).
    * It could be a permalinks-related issue. Resave your permalinks page to reset them. If you have permalinks turned off, turn them on with a structure like /%postname%/.
    * Switch to a different templating option under Settings –> The Events Calendar, using the dropdown.
    * Try increasing the PHP memory for your website:
    * Try to identify whether this is a conflict with another plugin. You can do so easily by deactivating any other plugins you’ve got active and checking whether the issue persists.
    * If it isn’t a plugin conflict, it may be a theme one. If after deactivating all other plugins the issue persists, please revert to the default 2011 theme and test whether it’s an issue there.

    Let me know how that goes, particularly after the final two steps. I’ll do what I can to assist from there.

    I just updated to the latest PRO version of the plug in and now everything looks insane? I don’t even have a “Google Map” link anymore.

    I am really confused as to why, but it looks like it is putting a template inside a template? I chose every template in my drop down list and have not received any acceptable results.

    Here are the urls where I am having some crazy issues:

    I tried looking through a few of your videos:; but nothing seems to really cover what I have going on.

    I have turned off all of the plugins and nothing changed.

    I followed your memory link, and updated my wp-config file to have: define(‘WP_MEMORY_LIMIT’, ’64M’); but I didn’t see anything update.

    Then when I changed my template to the default 2011 theme it worked. I am currently running the theme “Thesis 1.8.2.”

    Now, I don’t know what to do? If you could provide any help that would be great.


    Plugin Author Rob La Gatta


    Hey Carter: just wanted to confirm, you’ve brought this over to the PRO forums right? If you’re using the paid codebase now you have access over there and we generally are able to respond in a timelier fashion. We can keep the discussion going over at that other forum.

    Thanks for checking in. I did move this discussion over to the PRO forum, at this link:

    I got some help from Jonah. But, ultimately I had to reload the “Thesis 1.8.5” theme and replacing the “Classes” folder inside my “Lib” folder, and then I was able to get this to work.

    I still have a few questions about how the template for this plugin works which I have posted on the PRO forum here: Joyce is helping me so far with this one.


    Plugin Author Rob La Gatta


    Thanks for confirming this, Carter. Noted – if you find yourself with additional questions or unable to get resolutions on the threads you’ve posted, feel free to shoot me an email (rob at and I’ll personally jump in to see what can be done.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Plugin: The Events Calendar] Google Map Link Not Working’ is closed to new replies.