WordPress.org

Forums

The Events Calendar
Event Slug Issue (3 posts)

  1. aldrichdesigner
    Member
    Posted 3 years ago #

    Hey guys,

    I'm trying to configure 2.0 and it won't allow me to set the event slug to be index.php/events

    My server is windows server running plesk and it doesn't allow me to use normal permalinks. All my permalinks must start with index.php/. I'm going to try downgrading to 1.6.5 but I've already hit the migrate button so not sure if this is going to work or not.

    Any help would be appreciated, thanks.

    http://wordpress.org/extend/plugins/the-events-calendar/

  2. Shane Pearlman
    Modern Tribe
    Plugin Author

    Posted 3 years ago #

    you can't include a file name in a permalink - that much I am pretty sure of (but could always be wrong, certainly wouldn't be the first time). I'm not sure of how the solution would work. That could end up being a challenge since we depend on a functioning permalink system to work with wordpress url rewrites. We are going to work in 2.1 to see if we can get it working without pretty permalinks as a backup for people in your situation.

  3. aldrichdesigner
    Member
    Posted 3 years ago #

    Per WordPress.org

    If this isn't an option, you can try PATHINFO permalinks; put index.php/ at the start of your custom permalink structure:
    
     /index.php/%year%/%monthnum%/%day%/%postname%/

    We currently have to use the file name because it's on a windows server, don't ask why, cause I don't know. It's for a client and they refuse to migrate to linux. I'm working on getting the url rewrite module for windows installed but don't know if it will for sure happen or not. I'm hoping it does as right now 2.0 is my only resort unless I want to lose all their event info as it's already been migrated.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • The Events Calendar
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic