Support » Plugin: The Events Calendar » [Plugin: The Events Calendar] Error using 'post' – Fatal error: Call to undefined function

  • I just installed event calendar (auto install of plug in thru wordpress). I have the most current version of wordpress using the twenty-ten theme. Tried to created a calendar lising by using a blog post – get this error message:

    Fatal error: Call to undefined function filter_var() in D:\Inetpub\wwwroot\ra-wordpress.com\wp-content\plugins\the-events-calendar\the-events-calendar.class.php on line 883

Viewing 1 replies (of 1 total)
  • Same thing happening here.

    It turns out that filter_var() is a function available only in PHP 5.2 and above. Despite the fact that the Installation page says requirements PHP 5.1 or above.

    I thought WordPress had its own sanitising filters?

    PHP 5.2 was released in November 2006, so your host is either very out of touch or protecting legacy sites which might otherwise fall over. And if they haven’t updated yet there’s probably a good reason.

Viewing 1 replies (of 1 total)
  • The topic ‘[Plugin: The Events Calendar] Error using 'post' – Fatal error: Call to undefined function’ is closed to new replies.